close ad
 
Important WebAssist Announcement
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

I need help with accents in text.

Thread began 7/07/2023 7:40 am by Mike | Last modified 7/30/2023 7:06 am by Ray Borduin | 94 views | 4 replies |

Mike

I need help with accents in text.

A client of mine just changed hosting, but now I'm having problems with accented texts; for example, if there is "umidità" in the text in the database table, it shows up as "umiditÃ" on the website, and so for all other accents.

On the database configuration file is set: $MyConn->set_charset('utf8');
On the previous hosting, everything worked correctly but not anymore.

I noticed that the encoding of the tables in the database is switched from the previous one:
Default Character Set: utf8
Default Collation: utf8_general_ci

To this new encoding:
Default Character Set: utf8mb3
Default Collation: utf8mb3_general_ci

For your knowledge, I have applied to the file "rsobj.php" what is reported in this ticket ($this->Prepared = false;):
https://www.webassist.com/forums/posts.php?id=41498
However, accents did not work even before with "true."

Any ideas on how to solve this problem?
Thank you.

Sign in to reply to this post

Ray BorduinWebAssist

Prepared statement setting wouldn't effect the character display.

Character displays depend on three areas being in sync. The charset in the database column, the charset in the connection file, and the charset on the page itself in the html. If they don't match, then you can have character encoding issues. Make sure you have the charset correctly set in all 3 places.

I'd try changing the encoding back to the original value in the database. The utf8mb3 could be the issue.

Sign in to reply to this post
Did this help? Tips are appreciated...

Mike

The problem is that I can't find utf8 in the character set.
I have these options available:
armscii8
ascii
big5
binary
cp850
cp852
cp866
cp932
cp1250
cp1251
cp1256
cp1257
dec8
eucjpms
euckr
gb2312
gb18030
gbk
geostd8
greek
hebrew
hp8
keybcs2
koi8r
koi8u
latin1
latin2
latin5
latin7
macce
macroman
sjis
swe7
tis620
ucs2
ujis
utf8mb3
utf8mb4
utf16
utf16le
utf32

All the pages have this:
<meta charset="UTF-8">

Any alternative ideas? Is there anything I could ask the hosting provider?

Sign in to reply to this post

Mike

Fixed. The issue was with the database export tool (Navicat). I've changed the tool (PhpMyAdmin), and the accents render on the website well.

Sign in to reply to this post

Ray BorduinWebAssist

Thanks for updating the thread with your solution to help others that might run into the same problem.

Sign in to reply to this post
Did this help? Tips are appreciated...

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...