close ad
 
Important WebAssist Announcement
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Cannot get email to send in my webpage's email form

Thread began 2/12/2023 8:16 am by randyrie405335 | Last modified 2/22/2023 3:04 pm by Ray Borduin | 207 views | 6 replies |

randyrie405335

Cannot get email to send in my webpage's email form

I've placed a tab group on a php webpage that iframes in a history and a feedback form but neither work as expected. The history form places the collected data into the MySQL database but does NOT send out the email that I inserted into the page (via the Webassist Email menu item). Also, the Feedback form does not send out the email but returns with a "page not found" error.(I think I need a way to keep the action on the page?)

Please visit https://www.rjrwebz.com/rfl/contribute.php and see if you can determine what I've done wrong so that neither forms on the page work. I'm ending the webpage and the two include form pages for your review.

Hopefully you can spot why this isn't working? I can give you ftp access if needed.

(I'm using a macbook, macOS 11.7.2 (Big Sur), Xampp with php v7.3.11. I've also tried fixing this by remaking everything on a Dell Inspiron PC running Windows 11 and Xampp)

Thank you very much in advance for any help or advice.

Randy Riesterer

Sign in to reply to this post

Ray BorduinWebAssist

Remove the "action" attribute of your forms. That will make it automatically post to itself, which is where your code to process the form submission is located.

The action page is the only page that will get the form data. Your form currently posts to the main page and it doesn't have any of the insert or email code on it.

Sign in to reply to this post
Did this help? Tips are appreciated...

randyrie405335

Email and Insert still fail

Thanks Ray for your quick response.

I took your advice and rebuilt the History form with no action listed and now it does enter its data into the database.However, the feedback tab's email form will not load and displays no error even though I added the default=true to the queryobj.php page I've rebuilt the form several times but it always fails to load and no error is displayed.

Sign in to reply to this post

Ray BorduinWebAssist

If you update your queryobj.php page and change the setting:

->Debug = false;

to:

->Debug = true;

It should give you a better error we can use to figure out what is going on.

Sign in to reply to this post
Did this help? Tips are appreciated...

Ray BorduinWebAssist

Give me a call using the number at the bottom of this website, or text me through Skype: webassist.rborduin

Sign in to reply to this post
Did this help? Tips are appreciated...

randyrie405335

Thanks

Sign in to reply to this post

Ray BorduinWebAssist

I'll give you a call now.

Sign in to reply to this post
Did this help? Tips are appreciated...

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...