close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

STARTTLS with smtp?

Thread began 11/29/2021 7:06 am by MagsW | Last modified 11/30/2021 8:54 am by Ray Borduin | 23 views | 6 replies |

MagsW

STARTTLS with smtp?

Hi Ray, our client is moving their email to MS Exchange and I need to update the Universal Email settings we currently use to send email via their website. The details they gave me said to use STARTTLS, however the only options given in the smtp authentication settings are ssl and tls. I tried using tls (this is what the current script uses) but it didn't send. I also tried adding STARTTLS manually:

$Email->SMTPSecure = "STARTTLS";

That didn't work either. Is there a way I can use STARTTLS in the script?

Sign in to reply to this post

Ray BorduinWebAssist

It should work with:

$Email->SMTPSecure = "tls";

If it doesn't, turn on Debug and see what it says. Maybe you have to update the port.

Sign in to reply to this post
Did this help? Tips are appreciated...

MagsW

Turned on Debug and chose level 3 - where does the debug info appear? All I got was my own failure message that displays when a message doesn't go. I'm using the port number they gave me, which is 587, and have authentication to tls.

Sign in to reply to this post

Ray BorduinWebAssist

It should display it on the page... Turn off the redirect and that might help allow it to display. Level 5 might give more information.

Sign in to reply to this post
Did this help? Tips are appreciated...

MagsW

Got it to display this time - I've put the errors in the PM section but looks to me as if the problem is at the client's mailserver end, do you agree?

Sign in to reply to this post

Ray BorduinWebAssist

My guess is that your server has a firewall blocking port 587.

Try port 25, that might work. Otherwise talk to your hosting provider and see if there is a way to open port 587.

Sign in to reply to this post
Did this help? Tips are appreciated...

MagsW

I checked the firewall (it's a dedicated server) and port 587 doesn't seem to be blocked, however I tried changing to port 25 and it seems to have worked - just waiting for the client to confirm they've received the test email OK. Thanks for your help!

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...