close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Forgotten password wrong url

Thread began 3/11/2021 4:39 am by Sweens | Last modified 3/13/2021 11:20 am by Ray Borduin | 47 views | 11 replies |

Sweens

Forgotten password wrong url

Hi Ray

Having an issue with the forgotten password process. On some emails, a full stop is at the end of the url e.g. ...com&fp_data=inTMao6O9Tpm.

In the link in the paragraph 'password update' the url is correct, including the full stop at the end - but the full url that can be copied and pasted does not contain the full stop, so an error is returned.

I'll post an example in the private field.

Cheers
Chris

Sign in to reply to this post

Ray BorduinWebAssist

You should be able to adjust the page that sends the code to remove periods from the list of available strings when creating the link. If you attach the page I can show what line number needs to be adjusted.

Sign in to reply to this post
Did this help? Tips are appreciated...

Sweens

Thanks Ray - file attached.

Cheers
Chris

Sign in to reply to this post

Ray BorduinWebAssist

Can I get FTP access? I need to look at the email body and return pages and it will be easier to do with full access to the server for testing.

Sign in to reply to this post
Did this help? Tips are appreciated...

Sweens

see PM

Sign in to reply to this post

Ray BorduinWebAssist

I updated the file: webassist/security_assist/helper_php.php and made it encode the period. That should fix the problem.

Sign in to reply to this post
Did this help? Tips are appreciated...

Sweens

Many thanks Ray

Cheers

Chris

Sign in to reply to this post

Sweens

Hi Ray

Unfortunately, it has stripped the . from url's etc, so when the link in the text is clicked, the address fails.

It's only the full stop in the fp_data parameter that needs to be stripped.

When I try my address, both links work fine, but my colleague's address in the pm still always returns the full stop at the end of the url. Is it possible to sett the fp_data so that full stops are not used?

Cheers

Chris

Sign in to reply to this post

Ray BorduinWebAssist

It appears to work for me with the link you provided. What browser are you using?

Sign in to reply to this post
Did this help? Tips are appreciated...

Sweens

Hi Ray

Using Chrome and Firefox I get the error:

Notice: Undefined index: random_question in /home/sites/12b/8/8584b72192/public_html/forgottenpassword.php on line 287

Cgeers

Chris

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...