close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

confusing directions in tutorial

Thread began 2/03/2021 9:48 am by Peterson Design Studio - jefferis | Last modified 2/03/2021 1:45 pm by Ray Borduin | 28 views | 6 replies |

Peterson Design Studio - jefferis

confusing directions in tutorial

Ray, I'm doing a refresher course on creating a custom eCommerce site. Looking at the tutorials, I am not sure this instruction aligns with the image below it;
Now I'd like to draw your attention to a mistake commonly made when filling in the Server Folder and Web URL fields. Server Folder and Web URL must point to the same location. Otherwise, your product pages can't connect to your database. In other words, although you can name your site whatever you wish (I'm using ecommerce in this example), both of the fields must contain the identical site name. You should always verify a successful connection with the Test button before proceeding.
http://www.webassist.com/community/tutorials/attachments/234/887/var/www/vhosts/webassist.com/user_uploads/tutorials/attachments/234/887/proportion/product-catalog-setup-2_w692_h471/product-catalog-setup-2_09250349.jpg
I am developing using an IP address and am not sure which items need to be the same. (see attached photos) . The issue with the image is that in Mac DW 2021, you don't see servers and site on the same dialog box.

Also... I reinstalled MySQLi plugin but it never asked for my serial number. Is that right?

Sign in to reply to this post

Ray BorduinWebAssist

The root directory and the Web URL need to go to the same place.

In other words, if you put a file named test.php up from the root, then you must be able to browse it from http://66.39.111.101/test.php.

If you don't uninstall first, then it could keep your old serial and automatically re-activate.

Sign in to reply to this post
Did this help? Tips are appreciated...

Peterson Design Studio - jefferis

the root directory /dealerssupply.com is where the IP address points to and resolves. Are you saying instead of using the root directory path I need to put the http://IP address in that field?

Sign in to reply to this post

Ray BorduinWebAssist

I'm saying that Dreamweaver has to be able to browse the files that are uploaded using the url you entered. However you need to get them in sync, that is what you have to do.

Dreamweaver is going to FTP files up to your server and try to browse them. It will FTP them up to the directory specified as the root, and browse them using the url specified as the Web URL. If it can't do that, then it won't work.

Sign in to reply to this post
Did this help? Tips are appreciated...

Peterson Design Studio - jefferis

Okay. I think it is working as I have it set. However, I ran into a couple of problems. When trying to create a table new from blank, there were not options to create fields and the create "create table for me" was not checkable. Am I supposed to be able to design the table and fields from that interface? The product and ID fields, e.g., were not there, but I couldn't add any either. Do I need to create a blank table with PhpmySql first to get that to work?

And I created a user admin table from a preset, and it seems to have worked but see the error message attached. Now it seems to have stopped after creating the first page (users_insert) and stalled on creating the update page. So the error message may have locked it.

Sign in to reply to this post

Ray BorduinWebAssist

If you aren't using a preset, then you have to create the table and columns you need first.

The error may have been related to not having a table or connection set up properly. If you continue to get errors, please post your phone number in the private area and I'll screen share with you to figure out what is going on.

Sign in to reply to this post
Did this help? Tips are appreciated...

Peterson Design Studio - jefferis

I logged in to the database remotely. WA created the user tables, but failed to create the pages. Now not sure what to do. Also, when I look at the WA Database Connection panel, I see no connections

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...