close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Error messages with bootstrap design conflict with WAs validation

Thread began 8/05/2020 11:21 am by Jonas | Last modified 8/07/2020 1:39 pm by Ray Borduin | 28 views | 3 replies |

Jonas

Error messages with bootstrap design conflict with WAs validation

I want to redesign the "create account" page that Security Assist generates. And I want to use bootstrap as a framework for this, I think this is clean and nice. Both the elements themselves, but also the validation messages.

And this is where I run into problems. I have redesigned the form and added error messages, so it works with bootstrap. And I have kept the code created by WA, so this is also displayed. I want to take advantage of the advanced validation that WA offers.

But I only want to show bootstraps design for error messages, not WAs.

For example, bootstrap does not use the "title" tag inside the form field. This causes the error message to be repeated. Another example is that bootstrap uses <div class= "invalid-feedback"> which displays the error message.

Attached are two pictures. The first shows the form as a start. The other displays the form after pressing submit.

I do not want duplicate error messages. And I want Bootstrap's design. But with WA's error message.

Hope you understand what I mean.

Sign in to reply to this post

Ray BorduinWebAssist

I could help you with this in a premier support ticket. This is too complex to handle in a forum post directly.

Sign in to reply to this post
Did this help? Tips are appreciated...

Jonas

I have simplified the registration form now. I have deleted some fields that are not needed (first name, last name, city, postal code, country). At the same time I have added a field (Username). I have also added username to the database table, and selected it as unique. I have also changed the email to unique in the table because it seems more correct.

I have changed the validation. But there is something wrong. WAs validation is not displayed when you press submit. I have written an email address that is already registered, but no error message, even though I have created one. Can you solve this?

Sign in to reply to this post

Ray BorduinWebAssist

Actually I think there might be another error on the page. Call me and I'll do a free screen share to look into this.

Sign in to reply to this post
Did this help? Tips are appreciated...

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...