close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Search/Results aren't working using Search Wizard and DataAssist results pages

Thread began 5/05/2020 3:52 pm by tmcbinc99963 | Last modified 5/06/2020 8:00 pm by Ray Borduin | 37 views | 5 replies |

tmcbinc99963

Search/Results aren't working using Search Wizard and DataAssist results pages

Because the DataAssist 'pages' don't create radio or checkbox Search form elements, I used the Search Wizard to reconfigure an existing radio/checkbox form, and then created a results page using the DataAssist pages.

However, I can't get the Search page and Results page to work together.

In addition, the related recordsets created are lost every time the DataAssist Search server behavior is opened and edited.

Tried starting from scratch and having the Search Wizard create new from existing Db table along with a new results page. This doesn't work either, only returning all records.

I'd also like to add the search form to the top of the results page (the one created with the results page only has text fields). What is the best way to accomplish this?
Files are included.

Attached Files
Webassist.zip
Sign in to reply to this post

Ray BorduinWebAssist

Radio buttons and checkboxes work by submitting the value attribute. It looks like you have the values set to value="radio" and value="checkbox" instead of having the value set to what you want to be found in the database. I think if you just update the values it will work correctly.

You can always copy and paste the form onto the results page, or use the Framework->Insert Plugin server behavior to add it to the page that way.

Sign in to reply to this post
Did this help? Tips are appreciated...

tmcbinc99963

The Search Wizard search form was pasted into the Results page. Never got the pasted search form to submit any results, so I'm trying to convert the text fields from the existing Results page search into radio buttons and checkboxes.

I've partially succeeded, but the results have been mixed. The searches return unexpected results, even from the text fields, and some don't work at all, though they worked previously.

It seems as though the problem is in the way the queries are filtered in the Search Wizard. I've tried using different combinations in the Wizard, but none work consistently.

Also, how is a unique value added to each entry in a dynamic select list?

The page is attached. I can post live if that's easier to troubleshoot.

Sign in to reply to this post

Ray BorduinWebAssist

You have a couple of recordsets that seem to be repeated an unused.

I think you can update line 477 from $row_RsSalesCollateral['Headline'] to $row_WADASalesCollateral['Headline'].

Then you can delete lines 174-192.

That isn't the source of your problem, just clean up.

Next add this to the body of the page:

php:
<?php echo($query_WADASalesCollateral); ?>



That will show you the resulting query with the filter and allow you to see why it isn't working.

Sign in to reply to this post
Did this help? Tips are appreciated...

tmcbinc99963

I entered the code, but every search ends with: SELECT ID, Type, Category, Headline, MediaDesc, MediaName, Media, link FROM SalesCollateral WHERE (Type = '

I've deleted everything but the search form that's needed to make it simpler. But, I obviously don't understand how to set up the DataAssist Search recordset to search the relevant elements.

Rather than the dynamic radio button list I wanted, I've set it up where each radio button is independent (same with checkboxes). I've tried using select and check in the wizard, along with a php value and also an entered value. The entered value was the only one that would ever work, but don't see how the other records can be found using only one value. The checkboxes have the same issue. Does this require multiple recordsets or can I get the search results using the one DataAssist Search recordset?

Also trying to set up a keyword text field that will find everything but also works in conjunction with the buttons above it. This returns no results.

Now it's as if the form isn't even submitting, though the progress bar shows up briefly.

New page is attached.

Sign in to reply to this post

Ray BorduinWebAssist

It looks like you bound the filter to the recordset columns instead of entering the form element names. lines 16-21 should be something like:

$WADbSearch1->addComparisonFromList("Type","TypeFormElementName","AND","Includes",0);
$WADbSearch1->addComparisonFromEdit("Category","CategoryFormElementName","AND","=",0);
$WADbSearch1->addComparisonFromEdit("Headline","HeadlineFormElementName","AND","Includes",0);
$WADbSearch1->addComparisonFromEdit("MediaDesc","MediaDesc","AND","Includes",0);
$WADbSearch1->addComparisonFromEdit("MediaName","MediaName","AND","Includes",0);
$WADbSearch1->SalesCornerRadioGroup("Media","SalesCornerRadioGroup","AND","=",0);



With the actual form element names used from the search form.

Sign in to reply to this post
Did this help? Tips are appreciated...

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...