close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Binding Validated Fields Not Retained

Thread began 9/17/2009 11:55 am by Kevin373660 | Last modified 9/18/2009 7:28 pm by Jimmy Wu | 1262 views | 4 replies |

Kevin373660

Binding Validated Fields Not Retained

Using the WA Validation Tookkit, when setting up the Sever Side validations, I have bound the form element values the "Validated Entry" in the Bindings panel.

First form element passes. If second does not pass, after closing the popup error message the curser is placed inside the first form element and the values for both are removed. I am testing on local server running WinXP.

For elements after the first one, should I deselect the “Set focus to first invalid field?” What should I check?

Sign in to reply to this post

Kevin373660

I forgot to remove the redirect from the Authenticate php code block which is above the Server Validation code block which handles the redirect if validation fails ("failRedirect" => ""). Now the validation Show If messages show as they should.

Problem #1
However, the WA Server Validation (confiuration with the Validation Type: Email Address) for an email address can pass without containing "@" or "." values. It only stops if it is blank. Any sugestions?

Problem #2
After removing the redirect above I know have another problem and am not sure if it simply is reveling another errror. On a login page if you enter the correct username but an incorrect password you get redirected to the next page (sucessRedirect page). This was working fine before setting up the validation. When douple clicking on SecurityAssist Authenticate User Server Behavior the following error message pops up: "Error in server behavior Authenticate User: The value of the selectNode property is not a node in the document." I think that this is more a mater related to the authenication set up with Security Assist than validation? Any recomendations?

Sign in to reply to this post

Jimmy Wu

The email server validation should fail when there is no '@' or '.', you could try removing the validation and adding it again to see if there was an error applying it the first time.

What validations are you applying to the login form?

Sign in to reply to this post

Kevin373660

I tried that first and editied and then removed and reapplied the WA Server Validation server behavior twice for that page. The popup works with a blank but it will pass without the "@" or ".". Maybe it is something in the WAVT_Scripts_PHP.php file that is not being picked up. I think that I ran into this before but I am not sure that I had arrived at a solution. This is more important during the user registration validation which I am working on next.

When setting from the Tag <input> Behaviors panal ->Validtion Toolkit -> Apply Client Validations -> (what option should be selected?/WA Validation Tollkit Recipies (pg. 64 says "Required/Not Bank/Selection Made" should it be "Email Address"? I think that was the mistake I had made before.

The #2 problem was solved by removing the redirect code block that is mentioned in the procedures. It was in the Validation Toolkit Recipes pg. 61. It mentions correctly that, "code of this type is typically added to the page when standard server behaviors, such as Insert Record or Update Record are used." It is redundant to add a second redirect, and the comment assumes that I would figure that out.

Sign in to reply to this post

Jimmy Wu

Yes, if you apply the Email Address validation, this will validate to make sure that the email is in the correct format.

I apologize for the confusion on that issue. I am glad you were able to figure that part out.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...