close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

php errors on page/ layout is weird/ no email from form

Thread began 9/12/2009 9:13 am by chris384639 | Last modified 9/15/2009 6:25 pm by Jason Byrnes | 3483 views | 12 replies |

chris384639

php errors on page/ layout is weird/ no email from form

So I have 3 issues with my page. Hopefully I can post all three here. index3.php

1. I'm getting this error:

  Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /var/www/vhosts/prodentite.com/httpdocs/contact/index3.php:5) in /var/www/vhosts/prodentite.com/httpdocs/WA_ValidationToolkit/WAVT_ValidatedForm_PHP.php on line 3  



2. My form is making my page look weird. (Is that too much technical jargon :D)

3. I am using Universal Email to send the form data to my email. Why can't I receive it?

Thanks!!!!

Attached Files
index3.zip
Sign in to reply to this post

chris384639

Ok... I'm getting an email now from the form but it has no info in it...

Sign in to reply to this post

Jason ByrnesWebAssist

Are you still have the first two problems?

if yes:
1) the error message is being caused by the blank space at the end of line 4:
"?> "

trim the blank space at the end of that line:
"?>"

2) Please send a link so I can investigate the css.

3) Please send a copy of the WA_Universal_Email/WAUE_index3_1.php so I can look into how universal Email is configured.

Sign in to reply to this post

chris384639

Hi Jason-

I changed line 4... still have same problem.

Another issue- when I open the CSS Form Builder Edit Contents tab, I get these errors (please attached jpgs)

Attached Files
WA_Universal_Email.zip
index3.zip
Sign in to reply to this post

Jason ByrnesWebAssist

change line 5 and 6:
<?php virtual("/WA_ValidationToolkit/WAVT_Scripts_PHP.php"); ?>
<?php virtual("/WA_ValidationToolkit/WAVT_ValidatedForm_PHP.php"); ?>

to:
<?php require_once("../WA_ValidationToolkit/WAVT_Scripts_PHP.php"); ?>
<?php require_once("../WA_ValidationToolkit/WAVT_ValidatedForm_PHP.php"); ?>

Dreamweaver will use the virtual function if the "Create Links Relative TO:" option is set to "Site" on the Local Info tab of your site definition. Change it to "Document" So that Dreamweaver will use the require_once() function instead.

In the Universal Email server behavior, you have not used any of the Dynamic data bindings to output the form in the email.

Double click the Universal Email server behavior. On the body tab, click the DW Edit icon.

Open the bindings panel, and expand the form collection. Drag the Form element bindings where the information should be displayed.


For the form builder errors, try deleting the Dreamweaver cache file from the users configuration folder, more information can be found here:
common_installation_issues.pdf

Sign in to reply to this post

chris384639

Originally Said By: Jason Byrnes
  In the Universal Email server behavior, you have not used any of the Dynamic data bindings to output the form in the email.

Double click the Universal Email server behavior. On the body tab, click the DW Edit icon.

Open the bindings panel, and expand the form collection. Drag the Form element bindings where the information should be displayed.  




1. Ok... I'm not following you here. Where do I find the Universal Email server behavior tab? Do I go to INSERT>WEBASSIST>UNIVERSAL EMAIL?

2. Lost me here too. I see the Bindings panel, but don't see any FORM ELEMENTS option


Thanks

Sign in to reply to this post

Jason ByrnesWebAssist

1) To open the server behaviors, go to Window -> Server behaviors. You can double click on the Universal Email server behavior in the list.

2) What do you see in the bindings list. can you send a screen shot.

Sign in to reply to this post

chris384639

Opened DW and got these two errors:

Sign in to reply to this post

Jason ByrnesWebAssist

There was a brief problem with our activation server, it should be fixed now. Try rebooting you computer and re activating.

Sign in to reply to this post

chris384639

See screen shots:

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...