close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Validation

Thread began 2/05/2019 4:26 pm by john70964 | Last modified 2/13/2019 1:37 pm by Ray Borduin | 157 views | 30 replies |

john70964

Validation

Thank you for showing me the validation methods to be used in WA

I have now selected a field in this case Manufacturer.by the field I wrote Required.
I selected the field Manufacturer in the form and applied Server Validation
Validation Trigger Any Form Post
Validation type: Like entry
Session Variable, I select the Thunderbolt and the session list appears. There is no reference to the manufacturer in the session list.
Pls See attached.
Any ideas please?
Many thanks
John

Sign in to reply to this post

Ray BorduinWebAssist

You are trying to validate the form entry... not a session variable value. The only time you are validating against a session variable is when you are doing the CAPTCHA validation. The rest of the validations would only use the submitted form values.

Sign in to reply to this post

john70964

I have a form with a couple of fields where I would like to add
Validation show if.
I go WA > Forms > Validation > Validation show if
The "Validation show if" box opens with the correct page in the Validation page box.

When I hover over the plus signs the thumb icon appears but on clicking nothing happens.
Can anyone see why?
As you can see the Manufacturer field is selected although I can see ?ValidateField in the code.
This is a new page and no previous validations have been attempted.
Many thanks
John

Sign in to reply to this post

Ray BorduinWebAssist

Does the server validation server behavior display in the Server Behaviors window? You can't apply the Show If before applying the Server Validations server behavior beforehand.

Sign in to reply to this post

john70964

Thanks Ray
I cannot see any server behaviours in the server behaviours panel.
If I press the plus sign there is a New Server Behaviour selection in the list.
Should I select that?

Sign in to reply to this post

Ray BorduinWebAssist

You need to click the + button and choose:

Webassist->Validation->Server Validations

That must be applied before any Show If validations can be applied since they are based on that initial validation.

Sign in to reply to this post

john70964

Thanks Ray
I followed the instructions but when I view the page F12 the field that I applied the WA Server Validations to disappears.
Please see attachment

Attached Files
boat-insertShowIf.php
Sign in to reply to this post

Ray BorduinWebAssist

You have the validation show if applied around the field itself. It should be applied around a validation message that only shows if the validation fails.

Sign in to reply to this post

john70964

Thanks again Roy
I gave a big hurray because it worked and then I found my recordsets have disappeared. I can soon recreate then but it has happened several other times.
Just thought I would let you know.
Later:
I have the first field Manufacturer Validation showing correctly.
I then decided to validate the second field.
When I applied the validation to the Model Field in the Show Region IF it showed applying to manufacturer and I can see no way of changing this

Attached Files
boat-insertShowIf.php
Sign in to reply to this post

Ray BorduinWebAssist

This is an insert page, so usually there isn't a recordset, so I'm not sure what you are referring to. Sometimes dreamweaver can stop showing recordsets and you just have to close and open the page and it will show again.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...