close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Validation problems

Thread began 9/10/2009 3:37 pm by roby258376 | Last modified 4/21/2010 4:36 pm by jm271908 | 2928 views | 18 replies |

roby258376

Validation problems

Hi folks,

I am attempting to use CSS form builder and I have run into no end of difficulties with it.

My most pressing problem seems to be a problem with field validation.

I have had to remove validation from the radio buttons because even with radio buttons selected the form keeps telling me to choose one.

For my checkboxes, I have validation turned off and it's still telling me to choose.



any help would be appreciated.

Sign in to reply to this post

Jimmy Wu

I just tested the form and the form submitted both with and without the checkboxes checked. Did you make any changes to the form since you posted this thread?

Sign in to reply to this post

roby258376

Yes, I'm constantly trying to get the blasted thing to work as in intended.

Basically,

1) You'll notice that none of the radio button groups are required. I had to remove validation in order for the radio buttons to work. With "required" it didn't matter which was chosen, the validation error would pop up.

2) I tried creating check boxes (individual not group) to allow folks to choose "Areas to Search" but again, even without validation turned on, they were giving me the validation error messages and only by clicking every one was I able to submit the form.

so

3) I switched to a checkbox group instead, but now I can't get the checkbox group fields to show up in the email I am creating with Universal Email. Everything else is showing up, but the checkbox group fields are all blank.

So, still need major help please

Sign in to reply to this post

roby258376

I really need some help here please. And since we are no longer allowed to open support tickets by ourselves, but have to wait for someone from WA to open one from our posts on the forum, AND if we choose to chat, we are also told to post here and wait for a techy to open a ticket, I'd really appreciate it if someone could open a support ticket for me and get this figured out.

Thanks

Sign in to reply to this post

Jason ByrnesWebAssist

OK, I have opened a support ticket for you so we can figure out what is going wrong.

To view and edit your ticket log into your support history at:
supporthistory.php

Sign in to reply to this post

roby258376

Thanks, looking forward to getting it fixed.

Sign in to reply to this post

Ray BorduinWebAssist

I will try calling tomorrow to look into this further. Thank you for your patience.

Sign in to reply to this post

A Sound Design

I too have this problem. I use to be able to use the Radio group and get the form to validate UNTIL I STARTED TO USE UNIVERSAL EMAIL with Form Builder. Sorry to shout but I need to make that point really loud and clear.

To be honest I'm really angry about having to constantly post stuff here instead of being able to open a Support Ticket myself. It has taken me days to get a form to work by constantly having to post here and wait for a reply. I told a customer over a week ago that creating a form would only take a day. Now I feel like I am really incompetent as I cannot get any solutions.

Thanks for listening WA Support but please can I get a Support Ticket started myself????? When I was told that I got free support for signing up to the extensions library I didn't know it was going to take days to get something to work.

Sign in to reply to this post

anonymous

Jeremy,

I would be glad to take a look and help... do you have a link I can check out with the problem?

Also, just to confirm, if you were to remove the Universal Email (UE) behaviors, can you see if the form then validates? I think you should try to narrow down if in fact something has changed because of the UE or if it is the UE behavior, itself, interfering. In other words after adding the UE behavior, what happens now if you remove it?

The other thing that may be a quick fix is to ensure all the UE includes and attributes occur after the validations.

And one more question... is the validation problem client (such as spry, java, etc. or is it server side?

Best regards,

Brian

Sign in to reply to this post

A Sound Design

Hi Brian,

Hope you can help. I'll e-mail you a link to the URL as it's being tested and don't want to reveal it publicly yet, unless I can move it to a testing server on my own site.

Validation does work when you take the UE extension off. Indeed, it did work fine before I put UE on. I had the form mailed via a formmail script but took it off as it meant altering the code manually in Form Builder. I discovered that this caused serious problems rendering FB unusable, but that's another story.....

Anyway. I decided to use UE as I have it as part of the extensions library and thought that's what it's for, after all. (Doh!!!). It's only once I started using UE that the validation problems started. To cut it short, FB worked fine before adding UE.

In your reply you said "The other thing that may be a quick fix is to ensure all the UE includes and attributes occur after the validations." I'm not quite sure what you mean by that. How can I tell if this is the case?

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...