close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

issue with file manager and kcfinder

Thread began 9/05/2018 11:14 am by Marga-NL | Last modified 9/11/2018 1:15 pm by Ray Borduin | 34 views | 8 replies |

Marga-NL

issue with file manager and kcfinder

Hi, I updatend databridge to beta version 2.2.0 because my hostprovider will no longer support php 5.6 from next month. Therefore several customer websites have to be updated. So I am doing a testcase on one of my own websites and switched it to php7.1. On one of the (https) admin pages there is a file manager to upload images. When clicking the folder the new upload window opens (nice layout!). I can upload images. But when I select an image and click the 'done' button, nothing works. I have to close the window. The file field stays empty. What can be the problem?

Sign in to reply to this post

Ray BorduinWebAssist

Is there any way I could get FTP access? I'll have to debug it. It may have something to do with the javascript on the page needing an update.

Sign in to reply to this post

Marga-NL

Yes, see attachment.

Sign in to reply to this post

Ray BorduinWebAssist

I couldn't get in through FTP, but I think I found the problem.

Please replace this file:
/webassist/kcfinder/filebrowse.js

I've attached a new version that should fix this problem.

Attached Files
filebrowse.js
Sign in to reply to this post

Marga-NL

One problem solved, another problem still exists, concerning .htaccess in upload folder and showing the uploaded images on front- and backend.

Sign in to reply to this post

Ray BorduinWebAssist

I'll need FTP access to debug this. At the moment the page seems to be having the first issue where I can't even select an image from the file manager.

Sign in to reply to this post

Marga-NL

I will send you the details.

Sign in to reply to this post

Ray BorduinWebAssist

The problem was that Kcfinder adds a .htaccess file in your uploads directory. this htaccess file contains a line " Options -ExecCGI " that is not allowed in some hosts and causes an error preventing images from displaying

The solution is to prevent KCfinder from adding this .htacess file. This is easy by goiing to webassist/kcfinder/conf/config.php you will find this line :
'_check4htaccess' => true,

Change it to be false

I've done that for you and the page appears to be working now.

Sign in to reply to this post

Marga-NL

It works! Thanks Ray!

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...