close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

I've got some errors when creating pages

Thread began 8/27/2018 6:14 pm by mrs | Last modified 9/15/2018 7:16 pm by Ray Borduin | 114 views | 8 replies |

mrs

I've got some errors when creating pages

Hi Ray, I have just tested about four or five times the creating of a results, search and detail page, but I am getting errors on the detail page in that there is no select query being created at the top of the code and therefore I am not getting any data show... it just goes straight into doctype.

To try to force the creation (thinking I had done something wrong) I also included an insert page even though I don't need it. On the insert page I set one of the fields to be a checkbox and another to be a text field. My thought was I might need to declare some of this in order for the detail page to get the select code created. It did nothing to the detail page and actually caused unclosed tags on the results page. Also, the search page and detail page were not being saved once created, so that implies to me that the creation process has stopped before completing.

I've tested this with data bridge 2.0.3 and 2.2.0 and get the same result. Is there something I am doing wrong or is this a bug?

I've attached the files for your attention along with the product table and my XML schema that I saved from databridge.

I'm on a mac, using DWCC2018.

Thanks.

Mat

Attached Files
Archive.zip
TRProductPages.xml
tomrent_2018-08-27.sql
Sign in to reply to this post

Ray BorduinWebAssist

Please post a US phone number or Skype contact information in the private area of a reply to this thread and I'll call you and walk through this with you to try to determine what is going wrong.

Sign in to reply to this post

mrs

Hi Ray, apologies for the delay in responding. I've had issues with my skype!

Sign in to reply to this post

Ray BorduinWebAssist

Please try downloading and installing the latest version. I've made some updates since our last message and I'd like to confirm the issue hasn't been resolved before doing a screen sharing session.

Sign in to reply to this post

mrs

Hi again Ray, I've just got around to testing the latest version and there's still a problem with the results page not building correctly. I can't find it, but there seems to be malformed HTML (I've got yellow errors showing in design view) and any php code that should appear before the DOCTYPE declaration is missing.

Is my product table the cause of the issue?

Page is attached for you. If you think it's a bug and need to skype, I'll be available tomorrow evening from about 9pm UK time.

Thanks.

Attached Files
product_results.php
Sign in to reply to this post

Ray BorduinWebAssist

Yes. This page clearly didn't get created properly. I'll need to use screen sharing to debug it. I'll try contacting you at 2pm my time. I think that is 10pm your time tomorrow.

Sign in to reply to this post

mrs

Ray, I am so sorry, I had the worst night's sleep last night and I subsequently fell asleep at 8pm this evening and have just woken up... 2am!

Let me know when suits you again and I'll set an alarm to ensure I don't miss it.

If it's a week day, then any point from 7pm onwards will be fine. If for some reason you want to sort it over a weekend, then whenever suits you. I just want to make sure that I am not holding you up releasing.

Many thanks.

Sign in to reply to this post

Ray BorduinWebAssist

Please try this... Go to:

Webassist->Preferences

Then select "Wizard Settings" and change the delay to "long" and see if the wizard runs properly. Make sure to not click anything while the wizard is running.

Sign in to reply to this post

mrs

YES! Spot on Ray... you have thought of everything, haven't you?

I actually switched it to extra long and it still took less than 10 seconds! Brilliant.

Thank you very much

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...