close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Forgot Password - @@ConnectionPath@@

Thread began 5/20/2018 10:00 am by B Tonkin | Last modified 5/21/2018 8:45 pm by Ray Borduin | 53 views | 2 replies |

B Tonkin

Forgot Password - @@ConnectionPath@@

Testing out DataBridge and using it to 'Create Security Pages'. Noticed an issue so I'm reporting it in. Hope this is the right process.

It mostly works (creates the login, logout, registration and user update pages) however I thought I'd better test out the Forgot Password process. Starts out okay, but on submission it reports the following error ...

Fatal error: Uncaught Error: Class 'WA_Email' not found in /home/ahjsaas1/public_html/reports/webassist/security_assist/helper_php.php:176 Stack trace: #0 /home/ahjsaas1/public_html/reports/webassist/security_assist/helper_php.php(300): WA_Auth_SendEmail(Array, Array) #1 /home/ahjsaas1/public_html/reports/webassist/security_assist/helper_php.php(323): WA_Auth_ForgotPassword(Array) #2 /home/ahjsaas1/public_html/reports/forgotpassword.php(100): WA_Auth_ForgotEncryptedPassword(Array) #3 {main} thrown in /home/ahjsaas1/public_html/reports/webassist/security_assist/helper_php.php on line 176

Not sure exactly what the issue is, but on line 4 of the forgot password.php page I noticed the following ...

require_once('@@ConnectionPath@@');

I've let Dreamweaver go through the creation process a few times now but it always seems to keep that line in there when it creates the forgotpassword page.

Thoughts? What should it have in there?

On MacOS using DW CC 2018. Latest version.

Sign in to reply to this post

Ray BorduinWebAssist

That should be the path to your connection file... like: ../Connections/yourconnection.php

The other message is from missing email include files. They probably aren't getting copied over. You can just create a new blank page and apply the "Send email message" server behavior to get the files created and then upload the webassist/email server behavior to fix that one.

I'll look into these for fixes in the next update. Thanks for bringing them to my attention.

Sign in to reply to this post

B Tonkin

Thanks for that response, Ray. The Database Connection file was included on the next line so I deleted the other one.

Created the email files, uploaded them and then the whole login system worked beautifully.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...