close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Your PHP server doesn’t MYSQL module loaded ’t mysql_(p)connect functions

Thread began 12/02/2017 1:44 pm by birdscreen398247 | Last modified 12/05/2017 3:59 pm by Ray Borduin | 610 views | 9 replies |

birdscreen398247

Your PHP server doesn’t MYSQL module loaded ’t mysql_(p)connect functions

PHP 7, Dreamweaver CC

I get the above message when trying to define a connection using Webassist MysqlI behavior extension.

Sign in to reply to this post

Ray BorduinWebAssist

Have you tried going to Site->Advanced->Remove Connection Scripts?

Sign in to reply to this post

birdscreen398247

I did that and now I get

"HTTP Error Code 500 Internal server error"

Sign in to reply to this post

Ray BorduinWebAssist

Are you using localhost or a live server? I'd need to debug it. If you set it up on a remote server that I can ftp into I can test it that way and figure out the problem.

Sign in to reply to this post

birdscreen398247

Here is the remote server info. See private message.

Sign in to reply to this post

Ray BorduinWebAssist

I think the issue is that your folder name was "connections" and it needs to be "Connections". I updated that on the server and created a new connection and was able to test and view the data in Dreamweaver.

Sign in to reply to this post

birdscreen398247

Unfortunately, that killed all of my other connections to my website. I had changed the folder to lowercase because it is on a Linux server.

I will change it back and check the connections script for case.

Sign in to reply to this post

Ray BorduinWebAssist

Unfortunately Dreamweaver requires an uppercase connections folder. You can fix it in your .htaccess by adding:

RewriteRule ^Connections/(.*) connections/$1 [QSA,L]

that way your connections folder can be lower case.

Sign in to reply to this post

birdscreen398247

Where in Dreamweaver can I tell it to use the lowercase for the connections folder?

Sign in to reply to this post

Ray BorduinWebAssist

You can't. That is hard coded into dreamweaver. The .htaccess solution I gave above should make it work.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...