close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

mySQLi module not installed error after upgrading to PHP 7.1

Thread began 5/12/2017 12:50 pm by LionsMane | Last modified 5/12/2017 2:57 pm by Ray Borduin | 80 views | 8 replies |

LionsMane

mySQLi module not installed error after upgrading to PHP 7.1

apparently others are having this same problem. I upgraded my hosting to a new VPS supporting multiple versions of PHP, and as long as I'm using 5.6, my mySQLi functions work fine. As soon as I switch to 7.1, my DW functions fail with the well-known error: "Your PHP server doesn't have the MySQL or MySQLi module loaded or you can't use the mysql_(p)connect functions."

Have you found a solution to this yet? I modified the .js file someone else did, but that didn't help. Other thoughts? My Skype username is 'lionsmane'

Sign in to reply to this post

Ray BorduinWebAssist

Can you send me your ftp information and url? I'll test and see what I can find.

Have you updated to the latest version of the MySQLi Server Behaviors? We have made updates to correct this issue in the past.

Sign in to reply to this post

LionsMane

Info

FTP info below

Sign in to reply to this post

Ray BorduinWebAssist

I need the website url as well for the connection.

Sign in to reply to this post

LionsMane

URL

Originally Said By: Ray Borduin
  I need the website url as well for the connection.  
Sign in to reply to this post

Ray BorduinWebAssist

I'm able to connect to the database without issue using that connection. Try reinstalling the MySQLi Server Behaviors extension and make sure your site definition testing server is set up correctly.

Sign in to reply to this post

LionsMane

Try again

yes, that's because I had the site using v6.5 and not the problem version 7.1 I've changed that over.. please test again.

Sign in to reply to this post

Ray BorduinWebAssist

I'm still able to connect to the database without issues with the latest version.

Sign in to reply to this post

LionsMane

Me too

OK very strange. Now I'm able to create a connection in DW as well. I wonder if after making the .js change, I just needed to let things re-find themselves for it to work? Not sure.. sorry about taking your time.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...