close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Authorize.net - Disabling TLS 1.0 and TLS 1.1 does it cause any issue to eCart?

Thread began 5/03/2017 6:36 pm by ccdantas101117 | Last modified 5/05/2017 12:26 pm by Ray Borduin | 142 views | 3 replies |

ccdantas101117

Authorize.net - Disabling TLS 1.0 and TLS 1.1 does it cause any issue to eCart?

Does this from authorize.net cause any problem to eCart?
============= // ===============
Dear Authorize.Net Merchant:

As you may be aware, new PCI DSS requirements state that all payment systems must disable early TLS by 2018. Transport Layer Security (TLS), is a technology used to encrypt sensitive information sent via the Internet. TLS is the replacement for Secure Sockets Layer (SSL).

In preparation for this requirement, Authorize.Net plans to disable TLS 1.0 and TLS 1.1 on the following dates:

Sandbox: COMPLETE
Production: September 18, 2017

We have disabled the sandbox in advance of production to allow you and your developer time to test your website or payment solution and ensure you are no longer using TLS 1.0 or 1.1 prior to September 18th.

Please contact your web developer or payment solution provider, as well as your web hosting company, to confirm that they can support TLS 1.2 for your API connections.

Sign in to reply to this post

Ray BorduinWebAssist

Your hosting provider has likely already taken care of this for you.

In order to test, create a blank page on your server with this code:

php:
<?php

$ch 
curl_init('https://www.howsmyssl.com/a/check');
curl_setopt($chCURLOPT_RETURNTRANSFERtrue);
$data curl_exec($ch);
curl_close($ch);

$json json_decode($data);
echo 
$json->tls_version;
?>



That will tell you the TLS version installed. If it returns 1.2 you are all set, otherwise contact your hosting provider to get it updated.

Sign in to reply to this post

Supreme Geek

TLS 1.2 test code

Ray,
I created a blank PHP page and inserted your code. When I tried to view it online it just gave me the original code. Here's my page: http://lotcs.org/TLStest.php. Is there something that I'm doing wrong? Thanks in advance...
Dale

Sign in to reply to this post

Ray BorduinWebAssist

You pasted it in Design View and Dreamweaver automatically encoded it to display it on the page rather than run the code.

Paste it in Code View and it should run.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...