close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Google Map not showing on remote

Thread began 4/09/2017 3:44 pm by john70964 | Last modified 4/24/2017 2:27 pm by Ray Borduin | 798 views | 12 replies |

john70964

Google Map not showing on remote

Hello I have placed a google map on
http://net100.co.uk/sheringham-cottages/Map_Sheringham_Cottage.html using
webassist > Insert Google map

Although I can see this in localhost I cannot see it when using the remote server.

Would you please look at the page to see where I am going wrong .
Many thanks
John

Sign in to reply to this post

john70964

Please see PM

Sign in to reply to this post

Ray BorduinWebAssist

It is failing with an access denied message when it tries to use the google geocode service.

Google changed their requirements. Now you need to go in and specifically grant access to the maps.geocode service associated with the key you are using. Please try that and see if it fixes the problem.

Sign in to reply to this post

john70964

Thanks Ray,
I changed the api key I think the old one was out of date
and was able to see my credentials
the api key and selected referrers on the page which seems to suggest the api key is OK
However the map does not appear when used on the server localhost or the remote server.

It does appear before viewing in a browser

Sign in to reply to this post

Ray BorduinWebAssist

The geocoding service has to be enabled separately from the maps on the google api manager. Did you do that? It appears it is still rejecting the geocoding process for permissions reasons.

Sign in to reply to this post

john70964

please see pm

Sign in to reply to this post

Ray BorduinWebAssist

Using the link above:

1) Click on "Library" on the left menu
2) Under the "Google Maps API" click on the "More" link
3) Find "Google Maps Geocoding API" in the list and click it
4) Click "Enable" on the top of the page

Sign in to reply to this post

john70964

Thanks Ray
As you can see in the picture Google Maps Geocoding API is enabled. No joy seeing the map.
Regards
John

Sign in to reply to this post

Ray BorduinWebAssist

It has to be something with the API key settings. Maybe the IP address restrictions don't have the domain you are listing. I updated the page to use my API key and it works, so the problem isn't with the code on the page it is in the google settings.

From the same google console:
1) click on the credentials tab
2) select the api credentials you are using
3) where it says "key restrictions" choose 'none'

also make sure you have the credentials entered correctly

Sign in to reply to this post

john70964

Congratulations Ray!

Thanks Ray for that last information
By clicking "none" under API Key resriction the domain entries disappear and I get a warning message

Key restriction
This key is unrestricted. To prevent unauthorized use and quota theft, restrict your key.
Key restriction lets you specify which web sites, IP addresses, or apps can use this key

but the map is working now.

Is this going to be satisfactory to use?

Regards
John

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...