close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Mysqli update sb not updating page

Thread began 7/11/2016 11:39 pm by GaryMorris | Last modified 7/12/2016 6:04 pm by Ray Borduin | 707 views | 4 replies |

GaryMorris

Mysqli update sb not updating page

I am trying to make the update behavior work after creating a form with Webassist.
First off, I have created a form manually, assigned the fields from a record set, and then applied the update behavior and it works perfectly.

The problem comes when I create a form with Webassist ( so I can use the styling and the validation ). I create a form and bind the fields to the form. It comes up with the current values of the database with the userID I have requested. When I apply the Update Record server behavior, it goes to the index page like it ran but it does not change the database. I have tried binding to both the form and the validated form. Neither works.
Would sure appreciate some input..

Sign in to reply to this post

Ray BorduinWebAssist

I'd need to see a copy of the page in order to determine the cause of the problem.

Sign in to reply to this post

GaryMorris

I am sending you the edit.php page. There have been several iterations of this page so this is the current one. All had the same result.
When I go to do the Binding there are 3 forms available in the list. AdminUserLogin_Sharp_default, Current working form, and WA_validated_entries.
I figured I should use the first one, but have tried the others also.. The form does bring up the current values of the db.

By the way, I do not care if there is validation on this edit form. The add form has it and it works fine.

Thanks for the help.

Sign in to reply to this post

Ray BorduinWebAssist

Try just removing the form action. The current action isn't forwarding the ID that you are passing in the url and if you change it to action="" it will automatically forward it. That is probably the issue since it is trying to use the ID from the url to determine the updated record.

Sign in to reply to this post

GaryMorris

Once again you come through... I did have to remove the UpdateQuery->bindColumn("userID") line as it deleted the userID completely.. But now all is well. Wanted to make sure I could make it all work on a small form as I am getting ready to do a very large one... Thanks, and have a great day, until next time..

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...