close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

php.ini on hosted GoDaddy Server

Thread began 10/21/2015 10:51 am by mrobben375515 | Last modified 10/22/2015 3:21 pm by Ray Borduin | 1443 views | 11 replies |

mrobben375515

php.ini on hosted GoDaddy Server

I am having problems uploading a larger number of files to PowerGallery. I am getting this error message when trying to upload a 8mg file:

"Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 21480 bytes) in /home/content/05/11651305/html/1to1ecart/powergallery/admin_gallery/common/functions.php on line 257"

I increased the php.ini from 100mg to 256mg. This did not make a difference. I am attaching the php5.ini files.

I have an unlimited web hosting account with GoDaddy. Do I need to put the php.ini in each folder where the domain files reside or just in the main folder of my account? Currently these files reside in the root of the main domain's folder, which is 1 level up from the folder which holds the domain's folders the powergallery is inside.

Sign in to reply to this post

Ray BorduinWebAssist

It isn't the upload size that is the problem, it is the memory limit while trying to resize the image to fit in the gallery and display on the web.

To fix that, try updating the memory_limit variable in the php.ini file:
memory_limit = 256M ;

Sign in to reply to this post

mrobben375515

Can you confirm which folder the php5.ini file should be in please? I have an unlimited web hosting account with GoDaddy. Do I need to put the php.ini in each folder where the domain files reside or just in the main folder of my account? Currently these files reside in the root of the main domain's folder, which is 1 level up from the folder which holds the domain's folders the powergallery is inside.

Sign in to reply to this post

Ray BorduinWebAssist

It depends on how the server is configured. That might be a better question to ask your hosting provider. I'm not familiar with the type of hosting you are using and don't regularly use GoDaddy. Each hosting provider may have different configurations.

Sign in to reply to this post

mrobben375515

I uploaded the php files and still got this message. If the memory is set to 256mg, and the file uploading is 8817 KB, it should be working fine. Any suggestions? I am attaching the php5.ini and php.ini files to confirm there are no errors in them.

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 21480 bytes) in /home/content/05/11651305/html/1to1ecart/powergallery/admin_gallery/common/functions.php on line 257

Attached Files
php.ini
php5.ini
Sign in to reply to this post

Ray BorduinWebAssist

That must be the wrong location for the php.ini file.

If you add this code to the page:

<?php
phpinfo();
?>

You should be able to see the settings from the php.ini file and confirm if the memory_limit was updated or not.

Sign in to reply to this post

mrobben375515

Holy smokes that returned a lot of data. What should I be looking for? I am attaching a copy the response.

Sign in to reply to this post

mrobben375515

I did a search on the word "max". There the results I found showing the "local value" and the "master value" I am also attaching the file that I am uploading and that keeps giving me the error message.

Configuration apc:
apc.max_file_size 1M 1M

Core:
log_errors_max_len 1024 1024
max_execution_time 0 99999999999
max_file_uploads 20 20
max_input_nesting_level 64 64
max_input_time 99999999999 99999999999
max_input_vars 1000 1000
memory_limit 64M 256M
post_max_size 256M 256M
upload_max_filesize 256M 256M

mysql
mysql.max_links Unlimited Unlimited
mysql.max_persistent Unlimited Unlimited
mysqli.max_links Unlimited Unlimited
mysqli.max_persistent Unlimited Unlimited

session
session.gc_maxlifetime 1440 1440

PHP Variables
_SERVER["userlimit_limit"] 50
_SERVER["HTTP_CACHE_CONTROL"] max-age=0

Sign in to reply to this post

Ray BorduinWebAssist

The key value here causing issues is the value for: memory_limit

not anything with max in the name

Sign in to reply to this post

Ray BorduinWebAssist

Search for memory_limit on the page. It looks like you updated the master value, but the local value is still 64M.

You need to get the local value higher. It looks like it is still at 64M.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...