close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

XAMPP Not Working in Windows 10

Thread began 8/07/2015 9:59 am by salaroche | Last modified 2/03/2016 12:59 pm by Ray Borduin | 4633 views | 6 replies |

salaroche

XAMPP Not Working in Windows 10

Hi:

Yesterday I installed Windows 10 on my computer (Inspiron N5110, BIOS A11) and most things are working fine. XAMPP (Apache) however, refuses to start.

The error message I get is the following:

Error: Apache shutdown unexpectedly.
8:19:51 PM [Apache] This may be due to a blocked port, missing dependencies,
8:19:51 PM [Apache] improper privileges, a crash, or a shutdown by another method.
8:19:51 PM [Apache] Check the "/xampp/apache/logs/error.log" file
8:19:51 PM [Apache] and the Windows Event Viewer for more clues

Any suggestions on how to fix that glitch?

Thank you for your attention

Sign in to reply to this post

Ray BorduinWebAssist

I don't know.

I'd do what it says:
Check the "/xampp/apache/logs/error.log" file and the Windows Event Viewer for more clues

Then I'd try to find an XAMPP support forum and see if anyone else has had the same issues there. Please post back here when you find the solution.

Sign in to reply to this post

salaroche

Ray:

Thanks for your reply.

I had already browsed intensely around the Net before initiating this tread, but this morning I did come around the following solution:

Step 1 - From XAMPP Control Panel, under Apache, click the Config button, and select the Apache (httpd.conf).

Inside the httpd.conf file, find the line that says:
Listen 80
And change the 80 into any number / port you want, for example 8080.
Listen 8080
Still from the httpd.conf file, there is another line that says:
ServerName localhost:80

And change 80 to 8080.

ServerName localhost:8080

Step 2 - From XAMPP Control Panel, under Apache, click the Config button again, but this time select the Apache (httpd-ssl.conf). Inside the httpd-ssl.conf file, find line that says
Listen 443
And change the 443 into any number / port you want. Foe example 4433 as the new port number.
Listen 4433
Still from the httpd-ssl.conf file, find another line that says
<VirtualHost _default_:443>

ServerName localhost:443
And change 443 to 4433.
<VirtualHost _default_:4433>

ServerName localhost:4433

Remember to save httpd.conf file and httpd-ssl.conf after you make some changes. Then restart the Apache service.

XAMPP (Apache) is now running fine.

Sign in to reply to this post

salaroche

Ray:

Actually, changing the port number from 80 to 8080 does allow XAMPP Apache to start, but it doesn’t allow for http://localhost/phpmyadmin/ to open, nor for any DW page to open either.

The only other way out I have found is to disable the World Wide Web Publishing Service (W3svc), which is the Windows 10 service that uses port 80. This action might have some consequences later on, but I’ll deal with those as (and if) they arise.

In the meantime, XAMPP is working normally.

Sign in to reply to this post

Bill

Ever since getting Windows 10 I'm having a hard time with my testing server

Originally Said By: salaroche
  Ray:

Actually, changing the port number from 80 to 8080 does allow XAMPP Apache to start, but it doesn’t allow for http://localhost/phpmyadmin/ to open, nor for any DW page to open either.

The only other way out I have found is to disable the World Wide Web Publishing Service (W3svc), which is the Windows 10 service that uses port 80. This action might have some consequences later on, but I’ll deal with those as (and if) they arise.

In the meantime, XAMPP is working normally.  
Sign in to reply to this post

David

There is a fix

Since the introduction of Windows 10 many programs no longer work so get used to it.
In regards to xampp, it is as simple as using a pre-Bitnamy version such a 4.7.3 which you can find at sourceforge.net. After trying everything I could find on the web I decided to just get the older version.
Xampp and Wordpress were working on my PC within 20 minutes and still going strong.
Hope this helps.

Sign in to reply to this post

salaroche

I solved this problem a few weeks ago. I just got rid of Avast! and now everything works fine.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...