close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

TWO issues: 1) not looping through emails in a recordset - only sending email to 1 recipient; 2) having trouble embedding images within the body of the email.

Thread began 7/20/2015 5:30 pm by sandy170299 | Last modified 7/21/2015 12:51 pm by Ray Borduin | 321 views | 3 replies |

sandy170299

TWO issues: 1) not looping through emails in a recordset - only sending email to 1 recipient; 2) having trouble embedding images within the body of the email.

This is a mock-up for the time being, until I can get it to work, and the emails only come to me, so you can send as many as you need to. http://theartofsergio.com/create-email.php

All the images that I'm including in the dropdown lists have already been uploaded to the server, and are in one particular folder, which is being referenced in the dropdown listboxes. I have set it up so the label is the friendly image name, and the value is the name of the file stored in the database.

I do receive the emails, and have customized the template to include my form references, but it's really erratic - sometimes the images only show up as broken red Xs, and sometimes they all show up! I do not know why!

Also, it does not loop through the recordset - there are currently 4 email addresses in the database table, all valid email addresses coming to me, but I only get one email.

Thank you ... this is most frustrating! :)

See PM for FTP info.

Sign in to reply to this post

Ray BorduinWebAssist

You had just bound the TO field to the recordset value, but you need to click the TO button and open the sub-interface to bind it to "Recordset Loop".

I've made that update and uploaded the file so you can see.

Missing images may depend on the email client you are using. If you are using outlook it will block the images by default and then you can click "allow blocked content" to show them. I feel like that might be the issue.

I'd have to see a copy of the sent email to be sure. Feel free to forward it to me if you want me to take a look.

Sign in to reply to this post

sandy170299

Oh, and which is the file that you updated? create-email.php?

Thanks.

Sign in to reply to this post

Ray BorduinWebAssist

The only page I updated was: create-email.php

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...