close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Most of my pages are blank white, how to fix

Thread began 6/03/2015 7:29 pm by Webbie | Last modified 6/04/2015 6:59 pm by Ray Borduin | 356 views | 8 replies |

Webbie

Most of my pages are blank white, how to fix

Hello,
Yesturday i went through my website to try and clean up some things, it seems i was using editable regions and my templates incorrectly so i had to do some adjusting unapplying / reapplying pages to templates, so all my pages outside of my index page is connected to a template page for easy future editing.

I went through and changed my links on the template page, but for some reason most of my pages on my site are blank white? Does this have something to do with i had a theme on all the templates before the tweaking?

How do i fix my problem

Here is my site if you browse through you can see that there are alot bad or blank pages.

Please help, loosing customers !

Thanks

www.ativoitrecycling.com

Sign in to reply to this post

Ray BorduinWebAssist

Blank pages simply mean errors occur and aren't being displayed.

One option is to try turning on error reporting and that can possibly lead you to the solution.

Add this to the top of one of the blank pages:

<?php
ini_set('display_errors',1);
?>

and then browse it again. It could then give you an error message and line number that would lead you to the cause and solution.

If you post a URL to the page and FTP information so I can access the files I can help you debug and inform you of the cause as well, but that would be the first thing that I would do.

Sign in to reply to this post

Webbie

Thank you,
It looks like the errors are related to theme as i thought, im not very familiar with the theme and how it works.

I attached the code i got from the errors.

and will give you the ftp information.

It looks like i can just delete this code and re do the theme<?php require_once('webassist/framework/framework.php'); ?>
<?php require_once('webassist/framework/library.php'); ?>
<?php
if("" == ""){
$WA_booking_1413419793749_Content_Empty = "";
$WA_booking_1413419793749_Content = new WA_Include(__FILE__);
$WA_booking_1413419793749_Template = new WA_Include("schedule-pickup.php");
require($WA_booking_1413419793749_Template->BaseName);
$WA_booking_1413419793749_Template->Initialize(true);
}
?>

Or is there a path i can enter into the code to get it working?



Thanks

Sign in to reply to this post

Webbie

At this point im very confused, i know how editable regions work but i dont want to start playing with the theme because ive already lost the contect section for my the-company page.

What do i do without screwing stuff up, this site sees alot of traffic and need a safe solution

Sign in to reply to this post

Ray BorduinWebAssist

It looks like you haven't uploaded the file: Templates/contact.dwt.php to the live server.

When using Themes, the template pages have to be uploaded.

Sign in to reply to this post

Webbie

Ray...
No ill attach a pic of my that template file in my server.

1. There are some incorect php paths that need diagnosing, when i cut that out of my pages completly i am good to go.

I would just do that the problem i have is lost my content on this page http://www.ativoitrecycling.com/the-comany.php

because i do not know PHP.

Can you dig allitle deeper you have my ftp information above.

Ive added an attachment of a broken link that is probably causing the problem i just dont know how to re word it.




2. Also can is the content for that page i lost somewhere in theme land i can restore it, or do i have to redo the pages content?

Sign in to reply to this post

Ray BorduinWebAssist

It seems to be working now. Is there a broken page I should help debugging, or do you have this figured out?

Sign in to reply to this post

Webbie

I just deleted the theme code.

Can i redo the code without having problems?

The only content i want to have as editable is my main content, i remember theme need 3 areas.

I dont have three areas i will only have one, any suggestions?

Sign in to reply to this post

Ray BorduinWebAssist

You can do a theme with as few or as many editable areas as you want. If you try again and have problems let me know and I can look into it once I have a page that is broken to look at.

Maybe apply the theme to a test page at first to debug any issues without interrupting access to your site.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...