close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

DataAssist: Insert single record -> General -> database -> table : ***No Table Found

Thread began 12/06/2014 2:55 am by story.book.904 | Last modified 4/20/2015 12:58 pm by Ray Borduin | 1837 views | 22 replies |

story.book.904

DataAssist: Insert single record -> General -> database -> table : ***No Table Found

Following the tutorial video, I have reached the part where I was supposed to edit the "Insert Record(user)" under Server Behavior. However, I was unable to comply because no table is found and therefore the list under bindings is empty. When I go to phpMyadmin, under the database I was using for the site, everything was there as per shown in the tutorial video, except they were only contained in the Columns tab. Whereas the table itself under the Users tab gave this message:

MySQL returned an empty result set (i.e. zero rows). (Query took 0.0010 seconds.)

Having followed the tutorial to the teeth and redone it at least 6 times (due to other problems arising), I have no idea which part I did wrong to cause this. Please advise thanks.

Sign in to reply to this post

Jason ByrnesWebAssist

What tutorial is it you are following? I can't really help find what steps you may have gone wrong on without knowing what tutorial you are using.


It sounds like there may be an issue with either the site settings for the testing server, or the database connection. are you using a local testing server? is the connection properly set to connect to the database. Is the testing server running?

Sign in to reply to this post

story book

Oh sorry I didn't update this. The issue seemed to have solved itself eventually after I deleted everything and started from scratch, so maybe I did something wrong in between back then.

Sign in to reply to this post

Jason ByrnesWebAssist

ok, glad to hear it is working.

Sign in to reply to this post

mmichals347710

DataAssist: Insert single record -> General -> database -> table : ***No Table Found

Originally Said By: Jason Byrnes
  ok, glad to hear it is working.  



Hi Jason,
I'm having the same problem. It pertains to the web development tutorial on Double Opt In Registration.

When I reach the "Add the string to the database" section and double click the "Insert Record (users)" server behavior, the DataAssist: Insert Single Record dialog box appears but I cannot select any database table from either my local testing server or the remote server.

How can I manually update the PHP code to move past this step?

Sign in to reply to this post

Jason ByrnesWebAssist

The "Undefined Error Hs Occurred" error means that there is a problem with the Site settings for connecting to the Testing server.

Double check the site settings and make sure that the settings for the connecting to the testing server are correct.

If you are using an FTP connection to use the remote server as the testing server, you may need to enter a root directory if the connection does not go directly to the site root.

and make sure that the WebURL is the correct Web Address to connect to the server.

Sign in to reply to this post

mmichals347710

Verification Email Not Being Sent + Registration.php not registering new users

Thanks Jason, I got it working and finished the Double Opt In Registration development tutorial. But I have a new problem.

Do you have any idea why verification emails are not being sent? Also, the registration.php page is populating all of the "users" table fields with "NULL" with the exception being the randomString and emailVerified fields. Should I delete all the files and start over similar to what story.book.904 had done?

Sign in to reply to this post

Jason ByrnesWebAssist

"Do you have any idea why verification emails are not being sent?"

that can be for a number of reasons.

First, are you testing locally? if so that won't work for the emails, unless you have a SMTP server installed which is not a part of most local testing setups. you will need to test on the live server.

next thing to look at is the Insert behavior, is that set to redirect after the record is inserted? if so, that will prevent the email from sending. the redirect should be done in the email behavior.

if it's still not sending the email:
Who is your host?

Depending on your host, you may need to set certain options in Universal Email.

Some hosts will work if you leave the SMTP Server setting on the Email Server Tab blank, others will require that you enter the SMTP server address.

Some will work using the standard Mail protocol, other will require that you use the Pear Mail for SMTP, some using Pear mail will require authentication.

Some hosts may require that the from address being used be a valid email address for your domain. Some may require that the option to include the from Email address be passed as an extra parameter.

To be successful with Universal Email, you will need to know the requirements of your host for sending an email using a PHP script.

Also, double check your Spam folder, it is possible that the email is being trapped as spam.

As for only saving the random string, double check the insert behavior again on the registration page and make sure the columns are bound to the corresponding form elements on the registration page.

Sign in to reply to this post

mmichals347710

Verification Email Not Being Sent + Registration.php not registering new users

Originally Said By: Jason Byrnes
  "Do you have any idea why verification emails are not being sent?"

that can be for a number of reasons.

First, are you testing locally? if so that won't work for the emails, unless you have a SMTP server installed which is not a part of most local testing setups. you will need to test on the live server.

next thing to look at is the Insert behavior, is that set to redirect after the record is inserted? if so, that will prevent the email from sending. the redirect should be done in the email behavior.

if it's still not sending the email:
Who is your host?

Depending on your host, you may need to set certain options in Universal Email.

Some hosts will work if you leave the SMTP Server setting on the Email Server Tab blank, others will require that you enter the SMTP server address.

Some will work using the standard Mail protocol, other will require that you use the Pear Mail for SMTP, some using Pear mail will require authentication.

Some hosts may require that the from address being used be a valid email address for your domain. Some may require that the option to include the from Email address be passed as an extra parameter.

To be successful with Universal Email, you will need to know the requirements of your host for sending an email using a PHP script.

Also, double check your Spam folder, it is possible that the email is being trapped as spam.

As for only saving the random string, double check the insert behavior again on the registration page and make sure the columns are bound to the corresponding form elements on the registration page.  



Hi Jason,
I'm running the site off the remote server - I'm using Dreamhost.com. I think they were suggested by WebAssist before. Do you have specific SMTP setup instructions for Dreamhost? Here's their discussion forum: https://discussion.dreamhost.com/search.php

Not sure what you mean by whether the insert behavior is set to redirect after the record is inserted?

I already checked the spam folder and the email wasn't there. I did receive one verification email from the three times I tried which is strange.

Sign in to reply to this post

Jason ByrnesWebAssist

The first thing to check is the insert behavior.

open the insert record behavior and makes sure that it is not set to predict to another page. of it is, remove the redirect.

once you have validated that, we will look at the Dreamiest email server settings if it still does not work.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...