close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Unable to select database on SQL connection when trying to use SecurityAssist:create pages

Thread began 12/05/2014 1:51 pm by story.book.904 | Last modified 12/08/2014 3:51 pm by Jason Byrnes | 2428 views | 9 replies |

story.book.904

Unable to select database on SQL connection when trying to use SecurityAssist:create pages

After setting up a database in PHPmyadmin, I went on to open dreamweaver, created a new site which was in the folder D:\xampp\htdocs\site where the web url was http://localhost.
After that, I opened a new php sheet, clicked on the webassist->securityassist->create security pages as per the video tutorial and under database settings I clicked on define->new->mySQLconnection, entered the right username(root) and password and clicked on select beside the database, I get a return message saying:

HTTP Error Code 404 File not found. Here are some possible reasons for the problem:

1) there is no testing server running on this machine
2)The testing server specified for this site does not map to the http://localhost/_mmServerScripts/MMHTTPDB.php URL.

Long story short, I cannot continue to follow the tutorial video because eventually my tables will not be saved to the localhost, I have no idea which part I did wrong and needed remedying even after self troubleshooting and looking up similar problems on this site for over 5 hours and I'm about to just go into concussion in front of the keyboard at 3 in the morning.
Please Advise.

Sign in to reply to this post

Jason ByrnesWebAssist

the error means the web URL used for the Testing server settings in the site definition is not right.

you say you created the site folders at:
D:\xampp\htdocs\site

and the URL you are using is:
http://localhost


this is not correct. the http://localhost address maps to the root of the D:\xampp\htdocs folder.

where the site is defined as a subfolder of the htdocs folder, the address must include that subdirectory:
http://localhost/site

Sign in to reply to this post

story.book.904

It works!

Thank you so much!
For a future reference, if I want to do this for a paid FTP host instead of localhost, what folder would I save it in? Sorry because I have never done this before and planning to set up my own site.


Alright so now I have purchased a domain name and host server from Godaddy.com, they have given me the information which I then entered into my site setup where

Site name = Textroleplay
Local site folder = D:\xampp\htdocs\Textroleplay\

Server name = Textroleplay
Connect using = FTP
FTP address = 23.229.136.232 Port = 21
Username = user
Password = ******

At this point, I clicked test and it works.

Root directory = public_html/
Web url = http://textroleplay.com/

After saving, I checked the remote and testing boxes and carried on to webassist -> securityassist -> create pages -> connection: define -> new -> mySQL connection where

Connection name = textroleplay
MySQL server = localhost
Username = user
Password = ******

Database: select
Error message : An unidentified error has occured.

Please advice as I have no idea where the mistake might be.

Sign in to reply to this post

Jason ByrnesWebAssist

These FTP settings are on the testing server Tab?

If you open the Files panel, and change the focus to the testing server, what do you see?

Sign in to reply to this post

story book

I'm not sure how to put this but... when I check again 1 minute ago to reconfirm, the issue fixed itself and by what means I don't know. Sorry for the inconvenience.

Sign in to reply to this post

Jason ByrnesWebAssist

ok, glad to hear it is working.

Sign in to reply to this post

story book

Well now I have another problem. I'm pretty sure since every connection is successful when tested, there shouldn't be any more problems. However, when I finally got done with filling up all required fields in SecurityAssist: create pages and ran it, all files were created but it returned a message saying that it could not create tables for me, so the files were all saved in my webassist local drive. This problem has happened before when I tried with localhost but (referring to this thread) it was solved when I change the local folder. I know I can eventually upload my tables directly to my webhost but I don't want to do that. I want it to be uploaded when SecurityAssist creates them so I won't encounter another completely different set of problem in the future. Please advise?
Also, the input for MySQL server field in the security assist: MySQL Connection prompt is still localhost even though I'm uploading to a webhost, right?

Sign in to reply to this post

Jason ByrnesWebAssist

There are a number of reasons why the extension may not be able to create the table automatically. Most likely would be a permissions issue.

the extension will save the table settings to a SQL file that you can use to create the table manually, see this tutorial for details:
http://www.webassist.com/tutorials/Import-a-sql-file

as for the server address being localhost: maybe, maybe not, depends on the hot. If you are not sure, you should contact them.

Sign in to reply to this post

story book

I have called my webhost and was informed that all permissions are given, that I should be able to add tables to their phpmyAdmin with no issues. I tried manually and it worked. Are there any other possibilities I could try?

Sign in to reply to this post

Jason ByrnesWebAssist

There are too many possibilities for what could be going wrong. When you get that message, you should manually create the table.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...