close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

How to remove "LIMIT 1"

Thread began 11/26/2014 7:57 am by randyrie405335 | Last modified 11/26/2014 12:23 pm by Jason Byrnes | 317 views | 4 replies |

randyrie405335

How to remove "LIMIT 1"

MySQLi recordset builder is inserting by default a "LIMIT 1" SQL parameter. I cannot remove it via the builder (GUI) and if I remove the ",1" from within in the code, the recordset no longer displays in the Server Behavior panel. Is this a default setting I must defeat? If so, how?

Displayed in the code:

<?php
$rsAbstracts = new WA_MySQLi_RS("rsAbstracts",$icmids,1);
$rsAbstracts->setQuery("SELECT abstracts.* FROM abstracts");
$rsAbstracts->execute();
?>
<?php
$rsAuthors = new WA_MySQLi_RS("rsAuthors",$icmids,1);
$rsAuthors->setQuery("SELECT DISTINCT Author FROM abstracts ORDER BY Author ASC ");
$rsAuthors->execute();
?>

See "LIMIT 1" displayed in the attached screen capture of the GUI.

Sign in to reply to this post

Jamie

Hey Randi

If you want to return all records from a recordset you need to replace the 1 with a 0 (if you want to return a specific number of records, say 5, just replace the 1 with 5 or whatever number you want)

from this

<?php
$rsAuthors = new WA_MySQLi_RS("rsAuthors",$icmids,1);
$rsAuthors->setQuery("SELECT DISTINCT Author FROM abstracts ORDER BY Author ASC ");
$rsAuthors->execute();
?>



to this

<?php
$rsAuthors = new WA_MySQLi_RS("rsAuthors",$icmids,0);
$rsAuthors->setQuery("SELECT DISTINCT Author FROM abstracts ORDER BY Author ASC ");
$rsAuthors->execute();
?>
Sign in to reply to this post

randyrie405335

Thanks!

Yup - that worked, Jamie.

Wonder why MySQLi sets a " LIMIT" in the SQL by default and if there is a way to disable this?

Sign in to reply to this post

Jamie

Glad it worked!

I believe it just defaults to 1 but you are able to either manually change as above or use the mysqli repeat region function to select the number you want to set it to - I dont know if the default is changeable.

Jamie

Sign in to reply to this post

Jason ByrnesWebAssist

The default is not changeable.

It defaults to 1 to ensure that overlarge data sets are not created that could overload the servers memory and other resources.

The thinking is that if you are not using a repeat region to return more rows, then really you will most likely only use the first record in the result.

In the recordset you can set the limit to 0 if you don't want to add a repeat.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...