close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

No Database Selected

Thread began 11/05/2014 3:09 am by Zak | Last modified 11/05/2014 1:16 pm by Jason Byrnes | 293 views | 5 replies |

Zak

No Database Selected

I am moving a site from a local environment to a live server. I have copied the database and changed the php files in the "Connections" folder to match database credentials for the live server.

But, I'm receiving a no database selected message when on the live site.

I also changed the config files in the "webassist" folder as well but maybe not correctly and I did this while in the live environment.

Any suggestions on what I might be missing?

Thank you.

Sign in to reply to this post

Jason ByrnesWebAssist

No database selected means the information in the connection file is not correct.

Usually that happens if the database name is wrong. Double check the information in the connection file

Sign in to reply to this post

Zak

Ok, I double checked the database credentials and made sure the prefix was included, as directed by the hosting provider, but still getting same message.

I also receive these errors on the page:

Warning: mysql_fetch_assoc() expects parameter 1 to be resource, boolean given in /home4/whsbd/public_html/Test/WA_Globals/WA_Globals.php on line 41

Warning: mysql_free_result() expects parameter 1 to be resource, boolean given in /home4/whsbd/public_html/Test/WA_Globals/WA_Globals.php on line 67

If I delete these I can access the PowerCMS login page but when I log in I get the no database selected message.

Sign in to reply to this post

Jason ByrnesWebAssist

The error means that the connection information is not correct

the other errors also mean the connection info is not correct.

all 3 errors boil down to the connection file not having the correct information in them.

you should contact the host for help, I have no way of knowing what should be entered in the connection for your hosting provider.

Sign in to reply to this post

Zak

I went through everything again and found that it had to do with the created username. Error free now and working great. Thanks!

Sign in to reply to this post

Jason ByrnesWebAssist

you're welcome.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...