close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Search/Results page not showing all possible results

Thread began 9/08/2014 10:45 pm by Brendan | Last modified 9/09/2014 4:33 pm by Jason Byrnes | 563 views | 5 replies |

Brendan

Search/Results page not showing all possible results

This is on a live site, links are included for testing purposes below.

This is a school fundraising site where I have included a search/results page for parents to see how much $ their kids have raised, as well as an administrative search page, which allows my client to search all transactions.

I have one results page, where I can see results when I perform a search, but my client, and some of the parents cannot. here is the page
https://run4fundscolorado.com/antelope/ar-student-search.php - search last name "zeller" (username and PW in PM). If I pull this report, from this page, in FF, IE, Chrome, I see 4 results. My client doesn't see any?

Now, if they pull the admin report (https://run4fundscolorado.com/r4f-team/school-report.php) they can see all 4 transactions.

The other funny thing, is in another school I can see some of the results, but not all of them. Mind you, the identifier for the school is an uneditable field in the add2cart button. go to https://run4fundscolorado.com/ralston/re-student-search.php - search last name "hawley".

In these results, I am seeing 4 results, where if i pull the admin report, i am seeing 8.

This is really strange, not sure what is causing this. It might also be worth noting that my client printed out 1000s of flyers and promo information with each of the schools URL with capitol letters...so i've had to enable mod_speling because i couldn't build redirects for all of the stupid ways people were capitalizing.

Sign in to reply to this post

Jason ByrnesWebAssist

What browser is the client using?

you mention the mod_spelling implementation, so it would be worth double checking exactly the address the client is using in terms of the case, are they using a strange case combination to access the search, or exactly the same case as the link you provide?

when performing the search, are they using the enter key to submit or are they using the mouse to click the submit button?

Sign in to reply to this post

Brendan

The way mod_speling works, is that if my directory is "www.site.com/jason" and you type "www.site.com/Jason" the server compares what you wrote to the actual files on the server, and delivers the file that is closest. in other words, if you typed in /Jason, the browser would actually read /jason, as that is the directory that actually exists.

There are no printed links to the reports, the only way to access them is to click a link on the site, so everyone is arriving at the same URL as I am.

My client is using IE 9 or 10

I have tested in IE, FF, and chrome

Sign in to reply to this post

Jason ByrnesWebAssist

  when performing the search, are they using the enter key to submit or are they using the mouse to click the submit button?  



can you please address my last question?

Sign in to reply to this post

Brendan

I don't know, I assume they are clicking search - I must admit, my users aren't tech savvy, I asked which browser they were using and they responded "comcast"....which is their ISP. I've tried both, and it has no affect on the results. I've also sent the url (cut from my browser where results are present) in an email where they would simply click the link, and they weren't able to see the results there either.

Sign in to reply to this post

Jason ByrnesWebAssist

  ar-student-search.php - search last name "zeller" If I pull this report, from this page, in FF, IE, Chrome, I see 4 results. My client doesn't see any?" - what do you see?  



I see the 4 results, I Am not able to reproduce what the client sees. perhaps have them try to use a different browser like Fire Fox, or clear the browsers cache.


  re-student-search.php - search last name "hawley".

In these results, I am seeing 4 results, where if i pull the admin report, i am seeing 8.  



on the results page, you have a group by clause for the recordset:
GROUP BY DetailStudentL, DetailStudentF

this group by does not exist on the report page.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...