close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

MySQLi errors?

Thread began 8/21/2014 4:28 am by charles164095 | Last modified 9/02/2014 2:36 pm by Jason Byrnes | 559 views | 9 replies |

charles164095

MySQLi errors?

While building record inserts and record updates on new sites purchased on GoDaddy in the past week, I am suddenly getting the following error: "Not Acceptable An appropriate representation of the requested resource "my php file name" could not be found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request." Is this due to mysqli?. I have been using Dreamweaver 4 with Webassist Insert record Wizard for years and this is the first time I've seen this error.

Sign in to reply to this post

Jason ByrnesWebAssist

I'll need to troubleshoot directly, see the private message section.

Sign in to reply to this post

charles164095

Reply never received??

I had sent a reply with private message but see that the message is now missing. Was there something on my part that caused this to happen and do I need to resend?

Sign in to reply to this post

Jason ByrnesWebAssist

I cant say why the reply is not showing, but yes, you should resend the information.

Sign in to reply to this post

charles164095

Requested data enclosed

Private Message

Sign in to reply to this post

Jason ByrnesWebAssist

  If you enter a simple sentence or two in the editor it works fine. Try added several paragraphs (with or without code) and the error appears.  



that sounds to me like a probelm with the content column in the database, what is the data type for that column and the length set to?

Where it will take short data but not long, sounds like you may be using something like varchar (100) meaning it will accept up to 100 characters of variable character data.

you may want to change that column to varchar (500) or use the text data type.

for more on data types, see this page:
http://dev.mysql.com/doc/refman/5.6/en/storage-requirements.html

Sign in to reply to this post

charles164095

Text

Private

Sign in to reply to this post

Jason ByrnesWebAssist

This seams to be an issue with the mod_security settings on GoDaddy servers, it seams like either the Post Content such as the length of the field is triggering the mod_security to fail.

i can get this to work:

<p>
Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed sit amet tincidunt massa. Aliquam interdum pellentesque nunc eget tristique. In ut egestas urna. Vestibulum molestie ultrices dictum. Nulla felis ligula, tincidunt ut tellus eu, iaculis ullamcorper magna. Nullam accumsan diam nec dolor scelerisque, nec suscipit enim dapibus. Proin posuere tempor nunc, sed lobortis ante elementum rutrum. Nunc at efficitur risus. Nam sed rhoncus sapien, et cursus lorem. Sed ut accumsan nunc. Aenean sit amet tristique arcu, condimentum malesuada turpis.</p>



but not this:

<p>
Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed sit amet tincidunt massa. Aliquam interdum pellentesque nunc eget tristique. In ut egestas urna. Vestibulum molestie ultrices dictum. Nulla felis ligula, tincidunt ut tellus eu, iaculis ullamcorper magna. Nullam accumsan diam nec dolor scelerisque, nec suscipit enim dapibus. Proin posuere tempor nunc, sed lobortis ante elementum rutrum. Nunc at efficitur risus. Nam sed rhoncus sapien, et cursus lorem. Sed ut accumsan nunc. Aenean sit amet tristique arcu, condimentum malesuada turpis.</p>
<p>
Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed sit amet tincidunt massa. Aliquam interdum pellentesque nunc eget tristique. In ut egestas urna. Vestibulum molestie ultrices dictum. Nulla felis ligula, tincidunt ut tellus eu, iaculis ullamcorper magna. Nullam accumsan diam nec dolor scelerisque, nec suscipit enim dapibus. Proin posuere tempor nunc, sed lobortis ante elementum rutrum. Nunc at efficitur risus. Nam sed rhoncus sapien, et cursus lorem. Sed ut accumsan nunc. Aenean sit amet tristique arcu, condimentum malesuada turpis.</p>




you should contact godaddy to have them disable mod_security.

Sign in to reply to this post

charles164095

Results

private

Sign in to reply to this post

Jason ByrnesWebAssist

glad to hear you have it working.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...