close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

update page not updating

Thread began 8/05/2014 2:27 pm by Jamie | Last modified 8/07/2014 10:42 am by Jason Byrnes | 622 views | 8 replies |

Jamie

update page not updating

Hey Jason

Been bashing my head trying to figure out why the attached page does nothing when the update button is pressed.

Cheers

Jamie

Sign in to reply to this post

Jamie

ok have managed to figure out part of the problem - have uploaded the most recent version of the webassist/progress_bar/jquery-blockui-formprocessing.js

now the update button is working, but changes are not being posted to the db.....

Sign in to reply to this post

Jason ByrnesWebAssist

to help troubleshoot, change line 237:

$WA_Sql = "UPDATE `" . $WA_table . "` SET " . $updateParamsObj->WA_setValues . " WHERE " . $WhereObj->sqlWhereClause . "";

to:
$WA_Sql = "UPDATE `" . $WA_table . "` SET " . $updateParamsObj->WA_setValues . " WHERE " . $WhereObj->sqlWhereClause . "";
die($WA_Sql);


and post back the SQL that is written to the page when you try to update.

Sign in to reply to this post

Jamie

thanks for that Jason. used that and it showed me where I had gone wrong - was using the wrong key column id in the hidden field. all fixed and working now

thanks again

Jamie

Sign in to reply to this post

Jason ByrnesWebAssist

you're welcome.

Sign in to reply to this post

Jamie

Ok, this is a little strange.

After having a local site running fine and able to update/insert and delete content with no issues- I have sent the files to the live server and now some update/insert pages are working when the buttons are pressed and some are not. Same with the results pages where the delete button isnt working.

See PM for more details

Sign in to reply to this post

Jason ByrnesWebAssist

I am not able to reproduce the problems you report, The delete on the blog results page is working fine, also on the others the isnerts and updates are working for me and the HTML editor toolbar looks as it should.

perhaps you need to clear the browsers cache?

Sign in to reply to this post

Jamie

it would appear so! thanks Jason

Jamie

Sign in to reply to this post

Jason ByrnesWebAssist

You're welcome.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...