close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Problems with ecart 6 and sandbox.

Thread began 2/19/2014 5:07 am by CraigR | Last modified 2/20/2014 12:16 pm by Jason Byrnes | 653 views | 7 replies |

CraigRBeta Tester

Problems with ecart 6 and sandbox.

When I set up the payment gateway, I used my own (live) account api settings in order to test the connection to paypal (Paypal ECO).
Now this is working, I wanted to use a sandbox account to test the payment process so I can store the orders in the database on completion and trap any errors that may occur.
I opened the gateway credentials server behaviour and added Sandbox API credentials I know to be working (I tested them in a site I created with ecart 5) and I get a Security header is not valid error
I checked the code on the gateways page to confirm...

$WA_eCart_Debug_Mode = true;
// start gateway PayPal
// start settings PayPal API
$WA_PayPal_PayPal_API_TestMode = true;
if ($WA_PayPal_PayPal_API_TestMode) {
$WA_PayPal_PayPal_API_Username = "xxxx";
$WA_PayPal_PayPal_API_Password = "xxxx";
$WA_PayPal_PayPal_API_Signature = "xxxx";
} else {
$WA_PayPal_PayPal_API_Username = "yyyy";
$WA_PayPal_PayPal_API_Password = "yyyy";
$WA_PayPal_PayPal_API_Signature = "yyyy";
}
// end settings PayPal API
Sign in to reply to this post

Jason ByrnesWebAssist

I'll need to troubleshoot directly, see the private message section.

Sign in to reply to this post

CraigRBeta Tester

Will do, just need to update the test server

Sign in to reply to this post

Jason ByrnesWebAssist

see PM

Sign in to reply to this post

CraigRBeta Tester

PM

Sign in to reply to this post

Jason ByrnesWebAssist

you're welcome.

Sign in to reply to this post

CraigRBeta Tester

still not quite right

I found the line on pp_confirm.php

changed

$WA_PP_ECO_GetResult = WA_PP_ECO_Get_Post("liveapiusername", "liveapipassword", "liveapisignature", false);



to

$WA_PP_ECO_GetResult = WA_PP_ECO_Get_Post("sandboxapiusername", "sandboxapipassword", "sandboxapisignature", true);



but still get the error

No worries, I'll can wait until the update and try again

Sign in to reply to this post

Jason ByrnesWebAssist

Yeah, we should have an update to fix the problem available soon.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...