close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Picture not showing up properly after uploaded to folder. I see an icon only.

Thread began 1/23/2014 2:37 am by FPhu61701534 | Last modified 1/23/2014 4:43 pm by Jason Byrnes | 420 views | 9 replies |

FPhu61701534

Picture not showing up properly after uploaded to folder. I see an icon only.

I inserted the CKEditor into a page with image upload to a designated folder. The uploaded images would be inserted into the HTML editor. Unfortunately, I encountered the following problems:

1. The uploaded images do not appear at all when I browsed the folder. I can only see a grey box above the file name.
2. When I inserted an image, I see a red box with a cross. Strangely, 1 or 2 images appeared properly. I wonder why.
3. When I previewed the uploaded images, I can only see an image icon in the lightbox.
4. The target upload folder is "photos". But why do I see 2 folders by the same name whereby one is set as the root folder and another a sub-folder?
5. Where can I set the permission to allow only authorised person to access the upload folder? Do I need to create a database listing of authenticated users with login id and password?

See attached image for screencaps.

Sign in to reply to this post

Jason ByrnesWebAssist

1) many of the files in the webassist/kfm folder have become corrupted during the upload, the code on a lot of the files in that directory has become double spaced. this is causing the image thumbnail problem.


try using a 3rd party ftp program like file zilla to preform the upload to prevent this from happening

2) in the kfm configuration file, the user file path:
$kfm_userfiles_address = '../../photos';

was missing the trailing slash:
$kfm_userfiles_address = '../../photos/';

3) see the description for 1, it;s the same problem.

4) you see 2 folders named photos because there are 2 folders named photos. there is a photos subdirectory in the photos folder.

use security assist to create admin login. In webassist -> forms -> HTML Editor -> Site settings dialog, you can set the security assist user that has access to the file manager.

Sign in to reply to this post

FPhu61701534

Using 3rd party FTP program is not a good option because the web application is used by regular users who are not IT savvy. Is there any way to prevent the uploaded files from being corrupted? I mean the extension is supposed to work and I shouldn't resort to 3rd party programs.

Sign in to reply to this post

Jason ByrnesWebAssist

when i say the uploaded files, i mean the files in the webassist/kfm folder that you upload to the server for the website in order to use the file manager. I don't the files that a user would upload using the file manager.

Sign in to reply to this post

FPhu61701534

Yup, I understand that you are referring to the webassist/kfm files. Do I simply "repair" the configuration.php file by adding missing trailing slash?

Sign in to reply to this post

Jason ByrnesWebAssist

yes, that is correct.

Sign in to reply to this post

FPhu61701534

I added the trailing slash but the problem is still there. Can you check?

Sign in to reply to this post

Jason ByrnesWebAssist

did you upload the webassist/kfm files using a 3rd party ftp program like file zilla as I suggested.


I still see corruption in the webassist/kfm files.

Sign in to reply to this post

FPhu61701534

I had used DW's upload but seems that it doesn't work. Now I understand what you mean about using file zilla. It is working now. Just being curious. So what you are saying is that DW's upload feature actually corrupted the kfm files? By the way, there seems to be an image size restriction. How do I remove the restriction, and how do I set the image size to % based rather than pixel based?

Sign in to reply to this post

Jason ByrnesWebAssist

The Dreamweaver uplaod can sometimes cause corruption in the code.

i have normally seen it happen as a result of the Dreamweaver Preferences -> Code Formatting setting being set to anything other than LF (Unix), though that is not the only cause


the allowed image size is set in webassist/kfm/initialize.php:

$kfm->defaultSetting('max_image_upload_width', 1024);
$kfm->defaultSetting('max_image_upload_height', 768);


the file manager does not support percentages over pixals.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...