close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Dreamweaver F12 Preview in Browser with XAMPP Virtualhosts

Thread began 1/09/2014 4:38 pm by Kevin373660 | Last modified 1/10/2014 11:12 am by Jason Byrnes | 2029 views | 3 replies |

Kevin373660

Dreamweaver F12 Preview in Browser with XAMPP Virtualhosts

CONFIGURED:
Windows XP Pro
Windows Explorer 8
FireFox
Dreamweaver CS3
Installed: XAMPP Windows 1.8.1
Apache 2.4.7
PHP 5.4.7

I have tried to modify the appropriate files to utilize virtual localhosts from my test server. With Apache started (running) the following pages display in browser when URL is typed in to the address bar of the internet browser (Internet Explorer or FireFox).:

http://localhost/xampp/ -displays Xampp Configuration Window
http://localhost/xampp/yourdomainname/ -displays home index.html page

From the home page displayed in the browser, I can navigate through the localhost website: html, php, and txt pages. No Favicon displayed.

PROBLEM
However, from within Dreamweaver with webpage open, I cannot successfully Preview the page in the web browser (Internet Explorer or FireFox). The following message appears:

Internet Explorer cannot display the webpage

The browser address bar displays: http://loalhost/yourdomainname/testpage.php
I tried turning off the antivirus and firewall protection but this did not seem to help. This would indicate to me that some setting in the browser may be blocking displaying the page.

The Webassist tutorials are clear to install Xampp. But support documents and internet examples that I have read but do not go into detail about configurations or are conflicting.

Should the Preview from Dreamweaver work? Or is this to be expected? What configuration changes do I need to try?

Sign in to reply to this post

Jason ByrnesWebAssist

by default, xamp should be installed ton the c drive at:
c:/xampp


for this address to work:
http://localhost/xampp/yourdomainname/

the files should be at:
c:/xampp/yourdomainname/

in your site settings in dreamweaver the first step is to set the local files location, set the local files to be saved at:
c:/xampp/yourdomainname/

in the testing server section, use the local path:
c:/xampp/yourdomainname/

and the Web URL:
http://localhost/xampp/yourdomainname/


most likely what is happening is that you have the local path to another location, or the testing server path to another location.

if the local path is to another location, the files need to be put before browsing to them

if the testing server path is to another location, that wont map with how xampp is configured.

Sign in to reply to this post

Kevin373660

Jason,

Thank you for the fast reply. I have the Dreamweaver F12 Preview in browser working.

I followed your path logic and found that I had not corrected the hosts file correctly and accidently saved as a .txt file format.

I agree that in a standalone test web server environment the default install address is fine. However, I have several websites to work with and for security reasons I have installed Xampp on a different directory/partition.

The most resent Xampp now automatically detects the install directory and adjusts relavent code during installation, recommending that separate domains be install under in their separate site specific folder under the \htdocs directory.

X:\xampp\htdocs\yourdomainname1

--------------------------------------------------------
EDIT: C:\WINDOWS\system32\drivers\etc\hosts
--------------------------------------------------------

127.0.0.1 localhost
127.0.0.1 loopback
127.0.0.1 yourdomainname1

------------------------------------------------------------
EDIT: httpd-vhosts.config
------------------------------------------------------------
NameVirtualHost *:80

<VirtualHost *:80>
DocumentRoot "X:/xampp/htdocs"
ServerName localhost
</VirtualHost>

<VirtualHost *:80>
DocumentRoot "X:/xampp/htdocs/yourdomainname1"
ServerName yourdomainname1.localhost
<Directory "X:/xampp/htdocs/yourdomainname1">
Options Indexes FollowSymLinks
Order allow,deny
Allow from all
Require all granted
</Directory>
</VirtualHost>
====================================

Sign in to reply to this post

Jason ByrnesWebAssist

ok, glad to hear it is working

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...