close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

IE9 not playing nicely....

Thread began 1/08/2014 6:05 am by Jamie | Last modified 1/09/2014 11:12 am by Jason Byrnes | 313 views | 7 replies |

Jamie

IE9 not playing nicely....

Hey Jason

Just wondering if you would be able to take a look at the 2 attached images of the same page.

One is using Firefox (and it renders exactly the same in Chrome, Opera and Safari) whilst the other is in IE9 (ie10 is fine) and as you can see on that image with the 3 arrows, there are certain areas on the page which are not rendering as per the other browsers.

Obviously I understand the issues that we face with IE but thought that IE9 was pretty much on the same 'page' as it were as the other browsers?

Would you be able to help me troubleshoot so that I can get it working in IE9 please?

Many thanks

Jamie

Sign in to reply to this post

Jason ByrnesWebAssist

add overflow hidden to the container class for the main content, if yo8u need more details, provide a link where i can see it to troubleshoot.

Sign in to reply to this post

Jamie

Hey Jasoon.... have put the info in the PM

Many thanks

Jamie

Sign in to reply to this post

Jason ByrnesWebAssist

in the admin.css, remove overflow hidden from the body:

body {
background-color: #004899;
color: #2c2d2e;
font-family:Arial, Helvetica, sans-serif;
font-size: 11px;
margin: 0 0 0 0;
padding: 0 0 0 0;
text-align: center;
background-image: url(../images/body_bg.png);
background-repeat: repeat-x;overflow: hidden;
}



i don't think margin top is needed for the pages div

<div class="pages" style="float:left; width:220px; clear:left;margin-top:0;">


add overflow hidden to the #outerWrapper #contentWrapper #content

#outerWrapper #contentWrapper #content {
background-color: #fff;
margin: 0 0 0 240px;
padding:0 10px 0 0;
}

Sign in to reply to this post

Jamie

That doesnt seem to have had any measurable effetc - apart from the scroll bar coming back

Sign in to reply to this post

Jason ByrnesWebAssist

there was a problem in the template causing the page to use quirks mode (in quirks mode, IE uses the IE 5 rendering engine).

in the template, the line:
<?php require_once( "../WA_CMS/WA_CMS.php" ); ?>

needed to be moved from above the doctype to be in the head section.

Sign in to reply to this post

Jamie

superb - thanks for that Jason. All working fine and updated a few other sites with this as well

Cheers

Jamie

Sign in to reply to this post

Jason ByrnesWebAssist

you're welcome.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...