close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

No database selected

Thread began 11/04/2013 5:42 am by Jamie | Last modified 11/04/2013 5:14 pm by Jamie | 705 views | 6 replies |

Jamie

No database selected

Hey Jason

Am workign on a site... when I go to the home page I sometimes get 'No database selected' but then if I manually enter another page which then loads fine, and then click on the home button the homepage will load....

What could be causing this to happen...its very regular. Have put the URL in the PM

Sign in to reply to this post

Jason ByrnesWebAssist

I'll need to troubleshoot directly, see the private message section.

Sign in to reply to this post

Jamie

see PM

Sign in to reply to this post

Jason ByrnesWebAssist

see pm

Sign in to reply to this post

Jamie

Hey Jason

Its defintiely correct. Just logged on using the creds I sent you, downloaded the index page, made a mod and then uploaded it (still using the ftp deets I gave you) and the mod is showing on the live page.

Have attached again in case I mis uploaded int he first place....

Sign in to reply to this post

Jason ByrnesWebAssist

the host was wrong in the initial xml file you sent.

I'll be honest, i have no idea what is causing this issue, you are going to need to contact the host to have them look into it.

the problem query is the PageContents recordset. If i comment that recordset the page loads.

if i change the following line:
$PageContents = mysql_query($query_PageContents, $PowerCMSConnection) or die(mysql_error());

to:

$PageContents = mysql_query($query_PageContents, $PowerCMSConnection) or die(mysql_error()."<br />".$query_PageContents);

the error shows the SQL for that recordset:
No database selected
SELECT * FROM page_contents WHERE PageName = 'PageName'

if i add the following code near the </body> tag:
<?php echo($query_PageContents); ?>

and go to the about us page, then click the home link, it shows the same recordset SQL:
SELECT * FROM page_contents WHERE PageName = 'PageName'

so the SQL is not changing, but for some reason, the server is erroring on it. Your host will need to investigate why the same query works sometimes but not others.

Sign in to reply to this post

Jamie

cheers Jason

will get on to them

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...