close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Form submission not working

Thread began 8/17/2009 10:14 pm by info373020 | Last modified 8/18/2009 6:50 pm by anonymous | 1013 views | 3 replies |

info373020

Form submission not working

Hello,

I have a form that somewhat works. At least the upload and submit and server variables work. However in the other fields of the form, like 'name, 'email', phone #, do not come through on the email....

Can you help?

I followed the tutorial, and it say to paste

<?php foreach( $_POST as $pkey => $pval ) { ?>
<?php echo(str_replace("_"," ",$pkey).": ".($pval)); ?>
<?php } ?>

in the 'body' tab in universal email's plain text preview. I hit OK and it appears to take. I reopen universal email and go to the same 'body' tag, and the php code i entered there is gone.

Please help!

Thanks in advance

Sign in to reply to this post

anonymous

Just to clarify, when you say you reopen Universal Email, are double clicking the server behavior in behaviors panel... or are you just re-opening Universal Email?

I had a similar problem a while back and found that some other code on my page that I had chopped up was creating issues for everything else... I had to strip the page down and remove the Universal Email behaviors and then re-add everything one by one checking the code along the way.

Sign in to reply to this post

info373020

Sojo,

Hi Sojo,

Thanks for the reply...

I am clicking on the server behavior, not reopening a new universal email control. So your suggestion is probably to start over you think and just follow the code?



Thanks again,

Sean

Sign in to reply to this post

anonymous

I would recommend starting over but I don't know how much other stuff you have on the page. Is there any chance at all that something got corrupted when you working on the code?

Maybe try just a basic page with just your form and the Universal Email behavior. In other words, I would just try a new page - set up a form with just a few fields in it and then try the method to ensure that everything works properly. If that goes accordingly, then you will know for sure if the issue is bug related or something specific on your other page is problematic.

Your PHP code looks correct to me, so I don't think it is that.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...