close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Database connection problem - kind of

Thread began 8/28/2013 8:44 pm by mrsam5266 | Last modified 5/27/2014 11:04 am by Jason Byrnes | 1113 views | 14 replies |

mrsam5266

Database connection problem - kind of

This came on suddenly this afternoon. Everything had been going fine but when I tried to change a couple of server behaviors I started getting errors.

I then tried testing the DB connections and got this error:

HTTP Error Code 404 File Not Found. Here are some possible reasons for the problem:
1) There is no testing server running on the server machine.
2) The testing server specified for this site does not map to the http://72.167.232.227/aquadine/_mmServerScripts/MMHTTPDB.php.

There is a test server specified in the site settings and I can use the FTP in DW to view and upload files. I'm beginning to suspect that the script referred to in the error message has gotten corrupted somehow but wanted to check in before I did anything rash.

Some of the errors I was getting when I tried to access the server behaviors (from the login.php file) were about there not being the needed fields in the table so it was going to remove validations.

Sign in to reply to this post

Jason ByrnesWebAssist

this error points to a problem in the Site Settings of Dreamweaver, specifically the settings for the testing server.

double check the testing server settings in your site to make sure they are correct.

Sign in to reply to this post

mrsam5266

I double checked the FTP Romote/Testing server settings and I can get into the FTP in DreamWeaver and transfer files but continue to get the same error messages when I test the MySQL connection or try to access any of the server behaviors.

Sign in to reply to this post

Jason ByrnesWebAssist

it looks like the HTTP address you have entered in the testing serever settings is:
http://72.167.232.227/aquadine/

make sure that the ftp host directory is set to connect to the aquadine folder on the server.

Sign in to reply to this post

mrsam5266

Just double checked that and the Remote/Testing servers are set to go to the aquadine folder. When I open the full page FTP display in DW it goes right to the folder and displays all the files.

I'm attaching a copy of the script the error keeps referring to. Maybe something in there got dinged.

I just went to my testbed server and setup a new folder and connections. From this set of files and with this connection I can access the DB connection tests and the server behaviors.

The problem continues to be that after migrating the site to the clients host everything was working fine until they requested that I edit a redirect for the login page. Apparently the guy who is doing the SEO for them had started a backup of the databases and it hung for several hours. I didn't know about this and started getting the error messages when I tried to access server behaviors while this was going on and I haven't been able to get the connection tests or server behaviors to work since then on that host server.

Sign in to reply to this post

Jason ByrnesWebAssist

see private message

Sign in to reply to this post

mrsam5266

the hosting is through GoDaddy and they use the IP for all FTP functions. Trying to access a page using http://72.167.232.227/aquadine/index.php returns a 404 error.

I setup another Remote/Testing server using the top level URL as the host name and it does let me into the FTP that way.

I am now getting an error that says that the connection that was defined before is not found and to select a new connection but nothing comes up to let me do that. Where do I go to set a new connection for the database?

Sign in to reply to this post

Jason ByrnesWebAssist

the testing server connection needs to use the live, working URL.

go to the connection panel, Window -> Connections and click the plus button to define a connection.

Sign in to reply to this post

mrsam5266

There is no "Connections" item on the Window menu in DW.

Sign in to reply to this post

Jason ByrnesWebAssist

What version of Dreamweaver? DW CC?

if so make sure to install the deprecated server behaviors extension:
http://www.webassist.com/tutorials/Server-behaviors-for-Dreamweaver-Creative-Cloud

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...