close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

MySQL connection problems

Thread began 8/14/2009 2:13 pm by martistott342331 | Last modified 2/28/2017 11:39 am by Ray Borduin | 1287 views | 28 replies |

martistott342331

MySQL connection problems

I am using a PHP/MySQL system, and Dreamweaver 8. I am having the same connection problems with both SecurityAssisst and Datassist.

When I try to create the MySQL connection, I receive the following error:

MySQL error#: 1045

Access denied for user 'reflec3'@'localhost'(using password: YES)

Also, previous connections for another site that I have used with both SecurityAssist and Datassist successfully now show under the Dreamweaver tab as having no tables.

I have contacted my domain and attached a file that I copied from another site and changed the relevant info. such as login, etc. They report no errors with the file or problems reported with the database server.

Attached is the file that I submitted to the domain as an example.

Attached Files
mcc connection file.txt
Sign in to reply to this post

Jason ByrnesWebAssist

How have you configured the Testing Server Tab of your Dreamweaver Site Definition?


if you have set the testing server tab to use a local folder, when you enter Localhost as the mySQL server it will try to connect to your local computers mySQL server.

To connect to the remote MySQL server, set the testing server tab to connect to your remote host via ftp. other wise, if you have a local server up and running, use that instead, it will increase the speed of the Data Base panels if it does not have to connect to the remote host.

Sign in to reply to this post

martistott342331

testing server tab and connection problems

This post has been deleted.

martistott342331

remote server

It turns out that I did not use the correct server name (domain name) when setting up MySQL connection.

Sign in to reply to this post

GerhardC

Ongoing Error#: 1045 issues

I'm a novice:

I lost my phpmyadmin access details, ... no solution I could find on the Internet worked.
Thus, I unistalled Xampp and installed a new version of it - not all could be uninstalled, but I managed to copy across a new version of what seemed to be the offending file being "config.inc.php"

Now I have access to phpmyadmin again via "root" as the username. I have changed the password to "1234" (for now").
I use Dreamweaver CS6 and have set-up my site as follows:
- Connect using: Local/Network
- Server Folder: C:\xampp\htdocs\websitefolder\
- Web URL: http://localhost/
- Server Model: PHP MySQL

Trying to install Security Pages and arranging Database Settings and Defining the same by selecting a database on the testing server is troublesome:
- New, MySQL Connection
- Connection Name: MyConnection
MySQL server: localhost
Username: root
Password: 1234
Select database: .... Error message: "The testing server for this site does not map to the http://localhost/_mmServerScript/MMHTTPDB.php URL. Verify that the URL Prefix maps to the root of the site."

I have no idea what that means - please help?

To note, I have refreshed the browser appropriately and reset Xampp appropriately. Thanks for your help.

Sign in to reply to this post

Ray BorduinWebAssist

Your testing server should be:
Web URL: http://localhost/websitefolder

to match the directory where you are saving the files

Sign in to reply to this post

GerhardC

Xampp problems

Thanks very much. Now I have an error message that says Xampp does not see MySQL - please see the image attached.

Sign in to reply to this post

Ray BorduinWebAssist

That means you have to edit your php.ini file and enable the mysql module.

Find these lines in your php.ini file and make sure they don't have a semicolon in front of them:

extension=php_mysql.dll
extension=php_mysqli.dll

Sign in to reply to this post

GerhardC

Xampp problems

Thank you Ray.

I could not find a file called "php.ini" on my computer. But I did find another with reference to the lines you have noted. However, I could only find extension=php_mysqli.dll and not extension=php_mysql.dll. It did not have a semi-colon in front of it. So, I needed to not change anything.

Please see attached. Thanks.

Sign in to reply to this post

Ray BorduinWebAssist

What version of php are you running? You will have to have a version less than v7 to work with mySQL and not mySQLi.

If you create a page with this code:
<?php
phpinfo();
?>

It will tell you what version of php you are running.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...