close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Can't access uploads folder

Thread began 4/17/2013 4:49 am by MagsW | Last modified 4/24/2013 5:08 pm by MagsW | 827 views | 8 replies |

MagsW

Can't access uploads folder

I have HTML Editor installed on my Insert and Update pages. I can upload images to my uploads directory with no problems. However, when I try to insert an image using Image, Browse Server, I get the following message:

Forbidden

You don't have permission to access /(foldername)/uploads/ on this server.

The path to the uploads directory is correct and the folder permissions are set to 777. Any idea what's causing this?

Sign in to reply to this post

Jason ByrnesWebAssist

Try changing the upload folder permissions to 755 instead of 777, some servers don't like 777 permissions level

Sign in to reply to this post

MagsW

Hi Jason

I've tried that but I still get the same error. I also tried changing the uploads folder to the root of the site instead of in a subfolder, with the same permissions, but still won't let me browse. Error message:

Forbidden

You don't have permission to access /uploads/ on this server.

Apache Server at [domain.name] Port 80

Sign in to reply to this post

Jason ByrnesWebAssist

I'll need to look at the files on the server, see the private message section.

Sign in to reply to this post

MagsW

Hi Jason, details in private message below.

Sign in to reply to this post

Jason ByrnesWebAssist

IT seems safe mode is enabled on the server, the KFM File manager will not work with safe mode enabled

Sign in to reply to this post

MagsW

Originally Said By: Jason Byrnes
  IT seems safe mode is enabled on the server, the KFM File manager will not work with safe mode enabled  
Sign in to reply to this post

Jason ByrnesWebAssist

in the webassist/kfm/configuration.php file, the path to the uploads folder:

php:
$kfm_userfiles_address = '/uploads';



needed to be changed to:

php:
$kfm_userfiles_address = '../../uploads';




also in the /beemail_insert.php file, the file browsert settings:

php:
$CKEditor_config["filebrowserBrowseUrl"] = "/uploads?uicolor=".urlencode(isset($CKEditor_config["uiColor"])?str_replace("#","#",$CKEditor_config["uiColor"]):"#eee")."&theme=webassist_v2&showsidebar=false";



needed to be changed to:

php:
$CKEditor_config["filebrowserBrowseUrl"] = "../webassist/kfm/index.php?uicolor=".urlencode(isset($CKEditor_config["uiColor"])?str_replace("#","#",$CKEditor_config["uiColor"]):"#eee")."&theme=webassist_v2&showsidebar=false";
Sign in to reply to this post

MagsW

Thanks for sorting, working fine now!

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...