close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

DWfile.getAttributes

Thread began 1/13/2013 3:22 pm by derekmparker375520 | Last modified 1/18/2013 1:58 pm by Jason Byrnes | 1682 views | 22 replies |

derekmparker375520

DWfile.getAttributes

I'm using Data Assist with CS6 and am having trouble with the presets (I think). Everything works fine until I try to save the design as a preset, then I get this:

While executing timer in WA_SiteToolsProgressV2.html, the following JavaScript error(s) occurred: At line 4211 of the :Library:Application Support:Adobe:Dreamweaver CS6:Configuration:Floaters:WA_SiteTools_ProgrssV2.js": DWfile.getAttributes(orig) has no properties.

I tried just not using it as a preset, but if I do that and try to edit the form, the design is reset. Any ideas?

Sign in to reply to this post

Jason ByrnesWebAssist

Make sure you are using Data Bridge 1.1.2, if you have a previous version installed, uninstall it from the extension manager before installing the newer version, also, go to Window -> Work Space layout -> Reset '<your layout name>'

and Delete the Dreamweaver Cache file from the users configuration folder:
common_installation_issues.php

Sign in to reply to this post

derekmparker375520

Thanks for the reply. I checked to make sure I have the correct version of Data Assist (I didn't have a previous version of Form Builder). I deleted the Dreamweaver Cache file and reset the space layout but I'm still getting an error message when I click "Edit Form": Error Initializing Add Form UI: TypeError: DWfile.getAttributes(orig) has no properties.

Then I get the error from my initial post when I click Finish and it tries to update the form. It works fine as long as I don't save it as a preset, but I need to be able to get back in and change it without redesigning the form again.

Sign in to reply to this post

Jason ByrnesWebAssist

what extensions including version numbers are installed?

Sign in to reply to this post

derekmparker375520

CSS menu writer 2 - 2.0.6
Data Bridge - 1.1.2
Design Extender - 1.1.1
Dreamweaver Tools for Google - 2.0.4
eCart 5 - 5.0.6
Form Toolkit - 1.0.0
PowerCMS 1 - 1.0.2
Power CMS Builder - 1.0.1

Sign in to reply to this post

Jason ByrnesWebAssist

the only extensions you should have installed are:
Data Bridge - 1.1.2
Design Extender - 1.1.1
eCart 5 - 5.0.6
Free Tools


all of the other extensions are a part of either Data Bridge or design Extender.

uninstall all of the extensions, then reinstall in this order:
eCart 5 - 5.0.6
Free Tools
Design Extender - 1.1.1
Data Bridge - 1.1.2

Sign in to reply to this post

derekmparker375520

Thanks, I think that did the trick. I am having a couple more issues with it.

1. I'm not receiving the email once I submit the form. I have the "Send the form.." box checked in the Send Email Settings box and the email address and subject filled in.

2. I placed the form inside of a div and for some reason, the form starts about 200 pixels down within the div. I have margins and padding set to 0.

Sign in to reply to this post

Jason ByrnesWebAssist

1) Who is the host?

you may need to specify an SMTP Server in the email server settings.

to edit the universal email settings, open the server behaviors panel and double click the Universal email server behavior.

On the email server settings, you may need to set the SMTO server and port.

for the From settings, you may need to set a valid email address for your domain.

2) This means that the form is wider than the div it is contained in. to fix the probelm add overflow: hidden; to the div the form is in.

Sign in to reply to this post

derekmparker375520

The div problem is fixed, not sure why I didn't think of that. As for the email form, I can't find where to specify the SMTP server. The only thing showing up in my behaviors panel as far as Universal Email is "Universal Email 2 (webassist/email/template)" which only lets me edit the email format, to, from, subject, etc. I'm using Hostgator and the email I am sending it to is an email address on that server.

Sign in to reply to this post

Jason ByrnesWebAssist

in the universal email server behavior, along the top, click the envelope icon to set the email server settings.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...