close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Security Assist Issue

Thread began 9/17/2012 10:50 am by johna1964 | Last modified 9/17/2012 10:00 pm by johna1964 | 513 views | 4 replies |

johna1964

Security Assist Issue

Hi!

The Data Bridge Security Assist is not allowing security to any page I attempt to apply it to.

The code it there, but it's not working.

The pages that were applied with SA 2.0.5 are still working, but I have the upgrade to Data Bridge.

One of the pages are included.

Thank you!

johna1964

Attached Files
users_update .zip
Sign in to reply to this post

Jason ByrnesWebAssist

  The code it there, but it's not working.  


can you provide more details on exactly how it's not working?

are you getting error messages?

Please describe what is happening when you try to access this page versus what you expect to happen on accessing that page.

also, how is the Administrator access rule defined?

Sign in to reply to this post

johna1964

Hi Jason,

It's not working is about the only way to describe it...

It's not applying the security correctly to the page.

I uploaded all of these pages to the live server and did a test to see if any person could access the pages and anyone could by entering the file path even though not logged in - it should have redirected to the access denied page. So I deleted the pages from the server.

When I tried again on the testing server, the same thing happens. It should be redirecting to the access denied page, like the userupdate page created with SA 2.0.5.

I also tried to apply SA show region to the login page, so when an admin or power user logs in, links to the user information and the pages created by Data Assist can be accessed. If a new person creates a new account, initially these links are exposed - even though their user level status is 0. If a person already has an account,and logs in, the links are not exposed.

No error messages though

Hope this makes sense.

Thank you!

johna1964

Sign in to reply to this post

Jason ByrnesWebAssist

so it is allowing access to the protected page when it shouldn't?

how is the admin rule defined?

Sign in to reply to this post

johna1964

Jason,

It's working... I hadn't added the userLevel session value to the authenticate user server behavior... lesson learned again and hopefully forever...

Thank you for your time, and patience through all of this.

johna1964

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...