close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues


getting <br type="_moz" /> and <p> tags in db

Thread began 8/03/2009 11:44 am by JeanM | Last modified 8/07/2009 5:57 pm by Eric Mittman | 6015 views | 7 replies |


getting <br type="_moz" /> and <p> tags in db

in one iRite field the <br type ='_moz"/> tag appears in the db, and in the other field i 'm getting the <p></p> tags inserted into my db. my initial value formatting is set to "None". please advise.

according to the iRite documentation, "This happens if the Initial Value of the iRite instance is set to use formatting that converts HTML tags to HTML entities, in other words “<p>” to “&lt;p&gt;”. To fix this, select the iRite editor instance on your page and click the Edit button from the Properties inspector. Click the Initial Value lightning bolt and set the formatting to none."

Sign in to reply to this post

Eric Mittman

You can get it to store values that are encoded by using the htmlentities() function around the value that is being inserted into the db. So if you had an editor named myeditor you could wrap this function around the posted value that is being inserted like this:


Sign in to reply to this post


getting <br type="_moz /> in db in empty update fields

shoot, eric. i must not have been clear...
the iRite field is putting this text into my DB from a data assist UPDATE page, even when i am putting NOTHING into the field. i don't want to encode anything. the field is left EMPTY and the above is going into the db anyway. how do i stop it from happening? i want NOTHING in the db for these fields.
i have already checked the formatting on the initial value lightning bolt, and it is set to "None" as is recommended in the iRite documentation.

Sign in to reply to this post

Eric Mittman

Sorry about that, I misunderstood. I have tried to test this out with my own insert and update pages that have iRite applied to them and do not get this result. When I submit a blank value that is precisely what shows up in the db.

I even tried setting the formatting on the update page and so long as the entry in the editor is blank the field in the db is blank for me.

When you are on this update page what do you see if you click on the source button? If you can see characters there then you should delete them before updating the record to see if this helps. If you have more trouble with this and cannot get it sorted out post back with the update page or just the iRite instance code that you have on this page so I can see if it is set the same as mine.

In my testing if the editor was blank a blank value would be inserted into the db, if I have text then I will get the <p> tags around the content.

Sign in to reply to this post


<br type="_moz" /br> tags in empty db fields

Eric -
still no progress with a fix.
BTW: i dont see a "source" button on the update page. not sure what you're referring to... ?

however, i have discovered that this seems to be a FIREFOX / FCKeditor issue. all works perfectly in Internet Explorer. however, i am a Firefox user, and I also don't want to dictate to my clients that they MUST use IE in order for the backend to work properly.

i have found information online here: 1150
unfortunately, the fix they propose is not working for me. i've tried it.

what's happening is this: i have several iRite text fields on the insert & update pages. (the mySQL db field type is "text"). some fields i am leaving blank when inserting my data. if using IE, i get nothing in my db (great). if using firefox, i get <br type="_moz" /br> (YUCK).

i have tried everything in the "FORMATTING" tab of the iRite wizard. if i have the "Use <br> for return" box checked, i get the above tag. however, if i DESELECT this box, i get "&#160;" inserted into the db.

i have even gone into the .js file and tried editing.
1. with the "Use <br> for return" box checked, this line reads: FCKConfig.EnterMode = 'br';

2. with the box UNCHECKED, the line is: FCKConfig.EnterMode = 'p';

3. i've tried removing both and just using this line:
FCKConfig.EnterMode = '';

i am at a loss. i know i could use IE, but would like a fix for Firefox.

thanks, Jean

Sign in to reply to this post

Eric Mittman

All my testing was performed in Firefox, not IE. Please post back with the page that has the iRite instance on it or just the code you have on the page for the iRite instance so it can be checked for problems. If no problems can be found we can open a ticket so that you can post all your files and I can do some side by side comparison testing with my own.

Sign in to reply to this post


<br type="_moz" /> tags in db using Firefox

i'll attach the code in a .txt file (too many characters for this post). as i said, it all works fine in IE, just not Firefox.
if i leave ANY of the 4 iRite fields empty, i get "<br type="_moz" /br> inserted into the mySQL db. (text type field in db)

and, below is the code for the corresponding .js file for ONE of the iRite fields --> "more_info". the rest of the .js files all look like this one. i've tried every configuration i can think of in the "FORMATTING" tab of the iRite wizard to prevent this issue.

// Custom configuration for iRite

FCKConfig.SkinPath = 'skins/default/'; // relative to fckeditor/editor/fckeditor.html
FCKConfig.DocType = '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "">';

FCKConfig.AutoDetectLanguage = false;
FCKConfig.DefaultLanguage = 'en';

FCKConfig.StartupFocus = false;
FCKConfig.FullPage = false;

FCKConfig.BaseHref = '';
FCKConfig.DefaultLinkTarget = '_blank';

FCKConfig.ToolbarSets["Custom"] = [
]; /* Toolbar end */

FCKConfig.ForceStrongEm = true;
FCKConfig.FormatIndentator = ' ';
FCKConfig.EnterMode = 'br';
FCKConfig.FillEmptyBlocks = true;
FCKConfig.FormatOutput = true;
FCKConfig.FormatSource = true;
FCKConfig.IncludeGreekEntities = false;
FCKConfig.IncludeLatinEntities = false;
FCKConfig.ProcessHTMLEntities = false;
FCKConfig.ProcessNumericEntities = true;
FCKConfig.AdditionalNumericEntities = '';
FCKConfig.ForcePasteAsPlainText = true;
FCKConfig.CleanWordKeepsStructure = false;

FCKConfig.EditorAreaCSS = '../../sfep.css'; // relative to fckeditor/editor/fckeditor.html
FCKConfig.BodyClass = 'text';
FCKConfig.StylesXmlPath = ''; // relative to fckeditor/editor/fckeditor.html

thanks, jean

Attached Files
Sign in to reply to this post

Eric Mittman

From what I can see here and in the txt file it looks ok to me. I have opened a ticket for you, please login to and visit your support history to find the ticket then update it. Please include the files I will need to replicate this behavior on my end and also include a copy of your db. I will perform some testing and get back to you with what I discover.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question





Ease of use


security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...