close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

HTML Editor in Data Bridge

Thread began 6/03/2012 10:05 am by Dave W | Last modified 6/05/2012 12:54 pm by Jason Byrnes | 969 views | 5 replies |

Dave W

HTML Editor in Data Bridge

I am having a problem adding special characters in the HTML editor in the Data Bridge extension using DW CS6.

Every time I enter a special character via the special characters button, it shows as it's supposed to do, but when looking at the text on a webpage it is showing the characters as one of the following depending on which character you are trying to input "Ê, ë, Ý, Ò, Ð,ß, Õ".
This is for all all character with symbols above the letter (i.e acute, tilde, grave, etc). It is even showing the following for the registered, (® instead of ®) and copyright (© instead of ©) symbols.

Pulling it back in the editor shows the character as it is supposed to be, but clicking on the HTML button shows the characters NOT the HTML code for them.

I need to get this sorted as I am building a site that is in both French and English and I don't have a French keyboard.

Is this a bug or am I doing something wrong in the editor?

Dave Wadley

Sign in to reply to this post

Ian S

Do your database and web page character sets match up?

i.e Are they both UTF or ASCII?

Cheers
Ian

Sign in to reply to this post

Dave W

Yes they are both UTF-8

Sign in to reply to this post

Jason ByrnesWebAssist

use dynamic connections to create the database connection, and set the connection character set to UTF-8

Sign in to reply to this post

Dave W

Originally Said By: Jason Byrnes
  use dynamic connections to create the database connection, and set the connection character set to UTF-8  


I hear what you are saying Jason, but I shouldn't have to do that, but I will try it.

Just for the record I downloaded ckeditor from their site and installed it and THAT works fine without any problems, so I still think there is a bug in Data Bridge's HTML Editor that is causing this problem as it uses the same editor.

To add a codicil to this, I have tried your suggestion and it still doesn't work and still adds the weird characters as stated in my first post

Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
supporthistory.php

If anyone else is experiencing this same issue, please append to this thread.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...