close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

no testing server

Thread began 7/27/2009 12:06 am by tirzahm338096 | Last modified 7/27/2009 9:21 pm by tirzahm338096 | 2324 views | 5 replies |

tirzahm338096

no testing server

Attempting to connect to my database from within Dreamweaver and getting a HTTP Error Code 404 file not found. It then lists 2 possible reasons.
1. There is no testing server running on the server machine -
(I am running Apache and outside tests have worked fine. I have also set up the Testing Server in the manage site definition window, the server model is PHP MySQL and Access: Local/Network, testing server folder links to the htdocs folder)
2. The testing server specified for this site does not map to the _mmServer.... Verify that the URL Prefix maps to the root of the site.
(i have no idea what this means, the mySQL files are located at this path C:\ProgramData\MySQL\MySQL Server 5.1\data\mydb and my website files are the htdocs folder. Is that at all relevant?)

Sign in to reply to this post

Ray BorduinWebAssist

It looks like you may not have PHP installed properly.

Sign in to reply to this post

tirzahm338096

PHP is fine, phpinfo.php loads as it should.

Sign in to reply to this post

Ray BorduinWebAssist

Maybe a mismatch in your site definition. Make sure the HTTP address on the general tab matches the URL prefix setting on the Testing server tab.

Sign in to reply to this post

muddysmurf

I've always put everything (apache, mysql, and the php) folders under just C:\ and not inside the program folder.

What version of windows are you using? I've just installed all three of these things plus phpmyadmin on two Vista machines.

On my first try on the first Vista, php seemed to be working when I checked the phpinfo, but I couldn't get phpmyadmin to install correctly. Turns out, my php wasn't installed correctly with all of the right settings in the php.ini file.

Sign in to reply to this post

tirzahm338096

Ray - I think you were right, i did a slight adjustment in the site definition window and it works okay now. Updated the URL prefix to include the sub-folder name, i have no idea why that would fix this but it did. Thanks.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...