close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Data Assist error after created all pages

Thread began 3/20/2012 10:55 am by santosbr254895 | Last modified 3/20/2012 1:05 pm by santosbr254895 | 688 views | 2 replies |

santosbr254895

Data Assist error after created all pages

Hi Guys,
I have created a test page to use data assist. After I have created all pages by dataassist wizard and tried to see the pages on my browser I just see this message on the pages:
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'check
WHERE 0 = 1' at line 1

Even when I try to open a recordset in dreamweaver. a popup windows says:
MySQL Error#: 1064



This is my starting code in check_results.php


<?php require_once('Connections/Con_Check.php'); ?>
<?php
if (isset($_GET['S_ID']) && ($_GET['S_ID']) == "") {
$_GET['S_ID'] = "-1";
}
?>
<?php
if (isset($_GET['S_Nome']) && ($_GET['S_Nome']) == "") {
$_GET['S_Nome'] = "-1";
}
?>
<?php
if (isset($_GET['S_Usuario']) && ($_GET['S_Usuario']) == "") {
$_GET['S_Usuario'] = "-1";
}

.......

Thanks

Dungol

Sign in to reply to this post

Jason ByrnesWebAssist

that code block does not give enough to go on, it is better if you compress the page to a zip archive and attach the zip file to your message so I can see the entire page code.


judging from the error though, it looks like you have a column in your table named "check" which is a reserved word by the MySQL server.

MySQL reserved words should be avoided when naming your tables and columns.

a full list of reserved words can be found here:
reserved-words.html

a common naming convention that I use to avoid this issue is:

-Table Names: use the plural on naming tables:
products
users
options

-Column Names: use the singular table name as a prefix to the column name.
productID
productName

userID
userPassword
userFirstName
userLastName

optionID
optionName

-Both: Use camelCase to avoid illegal spaces, the underscore "_" can be used, but i don't recommend it.


using the singular table name as a prefix will ensure that you will never have 2 tables in your database that have the same name which can cause both errors and confusion. it will also prevent the posibily of using a reserved word. you will still need to be careful when naming the tables though.

Sign in to reply to this post

santosbr254895

Thanks for your help. It has a long time that I don't use database. I am not so much familiar with MySQL rules.
I removed "-" that I have used in my columns names like ( Prod-Name).
It is OK right now.
Thanks

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...