close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Security Code/Capcha Not Showing

Thread began 2/16/2012 1:42 pm by clinton178625 | Last modified 6/12/2012 5:39 pm by aladdin229745 | 2068 views | 12 replies |

clinton178625

Security Code/Capcha Not Showing

Hi Guys
I just installed a brand new version and the security code wont show? any help would be appreciated the page is here:
users_registration.php

Cheers Clinton

Sign in to reply to this post

Jason ByrnesWebAssist

trying to view the page that generates the captcha image:
WAVT_CaptchaSecurityImages.php

gives a 500 server error message, this is a very generic error that means "an error has occurred"


most likely it is because the GD Library is not enabled on the server.

contact the host to have them enable the GD library, if you still have the same problem, ask them to look into the error logs to see if they can find the actual error that is occurring, one we know the actual error, we can properly troubleshoot.

Sign in to reply to this post

clinton178625

Captcha Not working

Here is what my host company is telling me:

Hello,

Unfortunately, this appears to be a scripting issue, rather than server. As GD is already enabled;

root@traverse [/home/farmboyp]# php -i | grep gd
Configure Command => './configure' '--disable-cgi' '--enable-bcmath' '--enable-calendar' '--enable-dbase' '--enable-exif' '--enable-fastcgi' '--enable-ftp' '--enable-gd-native-ttf' '--enable-libxml' '--enable-magic-quotes' '--enable-mbstring' '--enable-pdo=shared' '--enable-soap' '--enable-sockets' '--enable-sqlite-utf8' '--enable-wddx' '--enable-zip' '--prefix=/usr/local' '--with-bz2' '--with-curl=/opt/curlssl/' '--with-freetype-dir=/usr' '--with-gd' '--with-gettext' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/opt/openssl' '--with-jpeg-dir=/usr' '--with-kerberos' '--with-libexpat-dir=/usr' '--with-libxml-dir=/opt/xml2' '--with-libxml-dir=/opt/xml2/' '--with-mcrypt=/opt/libmcrypt/' '--with-mhas! h=/opt/mhash/' '--with-mime-magic' '--with-mssql=/usr' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-mysqli=/usr/bin/mysql_config' '--with-openssl=/opt/openssl' '--with-openssl-dir=/opt/openssl' '--with-pcre-regex=/opt/pcre' '--with-pdo-mysql=shared' '--with-pdo-sqlite=shared' '--with-png-dir=/usr' '--with-pspell' '--with-sqlite=shared' '--with-tidy=/opt/tidy/' '--with-ttf' '--with-unixODBC=/usr' '--with-xmlrpc' '--with-xpm-dir=/usr' '--with-xsl=/opt/xslt/' '--with-zlib' '--with-zlib-dir=/usr'
gd
root@traverse [/home/farmboyp]#

And there are also no custom php.ini files in your accounts directories.

Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
supporthistory.php

If anyone else is experiencing this same issue, please append to this thread.

Sign in to reply to this post

micja

Originally Said By: Jason Byrnes
  I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
supporthistory.php

If anyone else is experiencing this same issue, please append to this thread.  



Just installed last night, and the page (security code) worked last night. Tonight it isn't. Attaching image and this is the link

Sign in to reply to this post

Jason ByrnesWebAssist

the file that generates the captcha image is here:
WAVT_CaptchaSecurityImages.php

this path is returning a 500 server error.

most likely this is a permissions issue.

using FileZilla to connect to your ftp server, change the permissions for the webassist/form_validations/WAVT_CaptchaSecurityImages.php file to 755.

you can do this right clicking it in FileZilla and select the Set Permissions option.

Sign in to reply to this post

micja

Originally Said By: Jason Byrnes
  the file that generates the captcha image is here:
WAVT_CaptchaSecurityImages.php

this path is returning a 500 server error.

most likely this is a permissions issue.

using FileZilla to connect to your ftp server, change the permissions for the webassist/form_validations/WAVT_CaptchaSecurityImages.php file to 755.

you can do this right clicking it in FileZilla and select the Set Permissions option.  



Hi Jason,
Thanks for the reply. I changed the perm settings and it didn't help. After reading the reply above I have also checked with our server tech support and asked if GD has been enabled. At this point they are saying it is either a code or a script error.

The strange thing is, I installed the program the night before last. Immediately after installation I went in and set up one user registration. The captcha appeared fine and the registration went through..
Then yesterday when I tried to set up another registration, the captcha wouldn't show up and so we couldn't set up the registration.

In addition, we keep receiving multiple "welcome to [the site]" and verification emails. So far we have receive them five times for the same registration.

Probably not the same issue...but both odd.

Sign in to reply to this post

Jason ByrnesWebAssist

For the captcha issue:
I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
supporthistory.php

If anyone else is experiencing this same issue, please append to this thread.


for the duplicate emails:
Go to the settings panel and open the Email Settings section, Increase the Seconds Between Email option to 2 or 3.

Sign in to reply to this post

aladdin229745

I have similar problem. However a different message

Fatal error: Call to undefined function imagettfbbox() in /home/realbrid/public_html/brides_register_here/webassist/form_validations/WAVT_CaptchaSecurityImages.php on line 125

Please can you help me with this one. Thanks

Sign in to reply to this post

Jason ByrnesWebAssist

this error means that the GD library or the Free Type Library is not enabled on the php server.

you will need to contact the host to have them correct the problem.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...