close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Lost Links after inclusion

Thread began 1/29/2012 4:05 am by clive.henderson222953 | Last modified 2/08/2012 4:42 pm by Jason Byrnes | 1315 views | 8 replies |

clive.henderson222953

Lost Links after inclusion

Hi
I have a page with a calendar with links that seems to work fine.
When I include it using Frame Builder the links don't work
Any help to solve this problem really appreciated.

The page with the calendar and link is here
calendar_ajax.php

A simple page with just the calendar included and nothing else is here but the links don't work

deleteme.php
Regards
Clive

Sign in to reply to this post

Jason ByrnesWebAssist

on the deleteme.php page, in the source, I see the following code:

function MM_goTourl(ch_includes) { //v3.0




the case of the function name is wrong. it should be:

function MM_goToURL(ch_includes) { //v3.0
Sign in to reply to this post

clive.henderson222953

Thanks for the reply Jason

function MM_goToURL(ch_includes) { //v3.0

I've checked the included file and the all goto codes are in the correct case.
It seems the he incorrect case happens when the file is included.
I'm afraid I don't know how to change the code in the deleteme.php file to correct the case to re-test.
Any help appreciated again.
Thanks
Clive

Sign in to reply to this post

Jason ByrnesWebAssist

send a copy of both pages please.

Sign in to reply to this post

clive.henderson222953

Thanks againJason , here are the 2 pages plus framework and library files

includeproblem.zip
Clive

Sign in to reply to this post

clive.henderson222953

Hello Jason
Was the link I sent Ok for the pages?
Kind Regards
Clive

Sign in to reply to this post

Jason ByrnesWebAssist

here is an updated copy of the webassist/framework/framework.php file to correct the problem.

Attached Files
framework.zip
Sign in to reply to this post

clive.henderson222953

Jason

Fantastic, Thanks very much!
All working well now.
Presumably, I need to use this file each time I include a such a file in future.

Anyway thanks again for solving the problem for me.
Kind Regards
Clive

Sign in to reply to this post

Jason ByrnesWebAssist

yes, you will need to use this updated framework.php file in each site.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...