close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Data Assist not writing upload value

Thread began 1/26/2012 8:15 pm by gjy5199349551 | Last modified 1/26/2012 8:58 pm by gjy5199349551 | 441 views | 2 replies |

gjy5199349551

Data Assist not writing upload value

Hi,

I am having an issue with DA and the upload file SB, the file filed added to the form after creation IS uploading the image however it is not writing the image name value to the database.

Extension background:
Pages were created with 2.0.8, after removing cache file and uninstalling/re-installing extension then recreating DA pages with the same results, I located the 2.0.9 release of DA and received the same results, upgraded to 2.1.0 which I am running currently.

I also had the same redirect issues many of the other users have mentioned and attempted to resolve with the advice in the forums, I updated the library files in all locations to the latest release in my downloads section with no improvement. The issue was resolved by commenting out the rel2abs function. The values of the upload field are blank either way, with or without the rel2abs function.

I should also mention, I have attempted to cure the situation by rearranging the order of functions on the page to see if the upload was executing too early with no positive results.

Regards,

Gary

Sign in to reply to this post

atstech

If you have applied the upload behavior using CSS Form Builder, double click the Insert Record server behavior. Click Next button to go to Step 2. Find your file field in the Insert values list. Click to highlight. Now click the lightning bolt button to the right of Value. You should see your Upload Files section for your file field. Expand the list and choose Server File Name. Click ok and then click Finish. This should now insert the file name of your image in the database.

Remember when wanting to display the image either on the following Details page or otherwise that you must include the path to the upload folder. Good luck.

Sign in to reply to this post

gjy5199349551

Solved

Thanks! worked great, I did need to remove the comments from the rel2abs function because the insert record SB failed to show otherwise. Then reapply the comments to fix the redirect issue.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...