close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Using URL to post to Results Page

Thread began 7/19/2009 1:35 pm by mcriecken380554 | Last modified 8/11/2009 10:50 am by Ray Borduin | 4068 views | 14 replies |

mcriecken380554

Using URL to post to Results Page

On my main page I have a navigation bar with a menu that lists different types of my inventory. I'm trying to get it to work so that when a user clicks on a type in the list, it will post to the results page with only that type. Here is the code I have in the URL link.

My_Results.php?type=Car

This brings up the results page fine, but it's showing all of my results instead of filtering out just those of a certain type. The field in my table is named type.

Sign in to reply to this post

Ray BorduinWebAssist

You would either have to add a parameter to the Recordset or apply DataAssist search in order to actually filter the results based on the passed url parameter.

Sign in to reply to this post

mcriecken380554

Question

Can anyone shed a little light on this for me? I'm not quite sure how to add a parameter like this to the recordset. I've already applied Data Assist Search Wizard to My_Results.php and created a search page. Basically, I'm wanting to have a list of categories on my main page that are each individual links to specific categories. I'm guessing I need to add a method to the results page to get the information on the results page? But I'm not quite sure how to go about doing that. Thanks in advance.

-Matt

Sign in to reply to this post

Ray BorduinWebAssist

Edit the recordset on the results page and add a filter using the interface provided.

Does your search page already have a category search option? If so you don't even have to edit the recordset, just mimic the url that the search page creates when doing a category search.

Sign in to reply to this post

Ray BorduinWebAssist

Edit the recordset on the results page and add a filter using the interface provided.

Does your search page already have a category search option? If so you don't even have to edit the recordset, just mimic the url that the search page creates when doing a category search.

Sign in to reply to this post

mcriecken380554

Filter

I added the filter to sort using a URL variable of Type. This allows my URL links to work just fine, however, with this filter active none of my other value searches will work. I've tried creating two different databases, one with a filter and one without, but this didn't work. When I take the filter off, my regular search functions work just fine. I do not have a menu search option to search by type, I am only wanting to create URL links to display certain type results. Thanks for all of your help.

-Matt

Sign in to reply to this post

Ray BorduinWebAssist

How did you do your other value searches? I doubt two databases is the way to go. It is difficult to give advice without a deeper understanding of what exactly you are doing and how it is working now.

Sign in to reply to this post

mcriecken380554

Filter

Here is an idea of what I'm trying to do. The page is a little messy, but this should give you an idea.

My_Search.php

Basically, I have the search fields as the main part of the search page. If you mouse over 'inventory' in the menu bar, it lists different types of autos. Ideally, when these different types are clicked I'd like the results page to display only the corresponding type. The problem I'm running into is that when I add the filter to the recordset (by double-clicking the recordset in the bindings panel), this causes my main search fields to stop working.

Sign in to reply to this post

Ray BorduinWebAssist

How did you do the original search feature? If you use dataAssist search in a current version for that, and a url parameter for the menu as you describe, it should work as you expect. I see it isn't working, so it has to be an issue with the original search implementation or the trigger in your dataAssist search server behavior.

Sign in to reply to this post

mcriecken380554

Filter

I think perhaps I'm just adding the filter incorrectly. I just redid my pages and applied a fresh DataAssist Search Wizard. Under the Server Behaviors panel I see the DataAssist Search that is used for all of my search functions. Do I need to edit the one already made? I'm confused because if I just double click on the recordset, and apply a filter for "Type", my links work just fine, but this causes my other search functions to stop working.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...