close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Powergallery V2 does not work properly!!

Thread began 10/23/2011 9:16 pm by Fernando Tuzzi | Last modified 3/01/2012 5:31 pm by biz295654 | 2169 views | 19 replies |

Fernando Tuzzi

Powergallery V2 does not work properly!!

Does not work properly, then bypass several obstacles during the installation with session management problems Finally I could install install it with the help of my hosting support.

Now I have crated a gallery but the style of the theme selected appears broken and in the admin panel when I try to view the preview of te lected theme this appear as blank page.

Here are the link:

cuero.php

Please a need a solution ASAP!!!

Sign in to reply to this post

Jason ByrnesWebAssist

in the webassist/caching/PG_CachedResize_Image.php file.

change line 14:
$retVal = is_dir($pathname) || @mkdir($pathname, 0777);

to:
$retVal = is_dir($pathname) || @mkdir($pathname, 0755);


and line 360:
mkdir ($cachefolder,0777,true);

to:
mkdir ($cachefolder,0755,true);



also, make sure that the permissions on the powergallery/images/ folder and all files and folders under it are set to 755

Sign in to reply to this post

Fernando Tuzzi

Powergallery V2 does not work properly!!

I have made all the changes that you suggested but still not working :mad:

Fernando Tuzzi

Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
supporthistory.php

If anyone else is experiencing this same issue, please append to this thread.

Sign in to reply to this post

biz295654

I purchased a second license for PG after checking with Jason exactly what to do with my server set up and all is good. I do think Safari cache has an issue, but if using another browser for editing in the system, all is good. So this is what I did to make for my particular server, per Jason's patience.


On some servers the permissions for the gallery and webassist folders and
all files and folders underneath need to be set to 755, and the
webassist/caching/PG_CachedResize_Image.php file needs to be updated to
change line 14:
$retVal = is_dir($pathname) || @mkdir($pathname, 0777);

to:
$retVal = is_dir($pathname) || @mkdir($pathname, 0755);


and line 360:
mkdir ($cachefolder,0777,true);

to:
mkdir ($cachefolder,0755,true);


From my experience... maybe it will help



And the admin_gallery/common/properties.php file needs to be edited to
change:

$GLOBALS['permissions'] = array(
'dir' => 0777,
'file' => 0666
);


To:
$GLOBALS['permissions'] = array(
'dir' => 0755,
'file' => 0755
);

Thank you Jason for explaining it for me so I can address. Very much appreciated.

Sign in to reply to this post

biz295654

A new install of PG is giving me the same permissions issue. I changed the 777 references in webassist/cashing/PG_CachedResize_Image.php file on line 14, 360 and in common/properties from 0777 / 0666 to 0755 etc.

But still no luck. Is there another 777 setting I need to address?

Thanks

Sign in to reply to this post

Jason ByrnesWebAssist

using filezilla, change the permissions on the gallery folder and folders and files underneath to 755.

if the files are already created with 777 permissions, the code change wont reset them, that needs to be done manually in filezilla or another dedicated FTP program.

Sign in to reply to this post

biz295654

I found this one too:
unction deleteDirectory($dir) {
if (!file_exists($dir)) return true;
if (!is_dir($dir) || is_link($dir)) return unlink($dir);
foreach (scandir($dir) as $item) {
if ($item == '.' || $item == '..') continue;
if (!deleteDirectory($dir . "/" . $item)) {
chmod($dir . "/" . $item, $GLOBALS['permissions']['dir']);
if (!deleteDirectory($dir . "/" . $item)) {
chmod($dir . "/" . $item, 0755);
deleteDirectory($dir . "/" . $item);


I did check folders and they are set to 755 ...Using Transmit to look at them. I'll double check again. Thanks.

Sign in to reply to this post

biz295654

Well, they all look like they are set to 755.

I can reverse what I did and then set the folders to 777. Would that solve it?

Sign in to reply to this post

biz295654

Before I try that, take a look please at a test using the include. Click in the middle of the page.


testgallery.php

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...